PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 26 → application linux
application linux
Débuté par ALICE, 10 juin 2021 15:36 - 26 réponses
Membre enregistré
39 messages
Posté le 10 juin 2021 - 15:36
Bonjour je tente de développer une application pour linux .
Lorsque j'exécute l'application il me met erreur : la librairie QT version 4.5 minimum est necessaire

En ligne de commande j 'ai tapé :
sudo apt-get install libqtcore5
sudo apt-get install libqtgui5
Ca ne fonctionne pas

Avez vous une idée¿
Merci
Alice
Membre enregistré
76 messages
Posté le 10 juin 2021 - 16:13
Bonjour,

En fonction de la distribution Linux utilisée la commande pour installer une application change. La commande "sudo apt-get install" est utilisée pour Ubuntu mais si vous utilisez une autre distribution la commande sera probablement différente.
Membre enregistré
39 messages
Posté le 10 juin 2021 - 18:00
Bonjour
Je suis sur Unbuntu
Cdlt
Alice
Membre enregistré
76 messages
Posté le 11 juin 2021 - 08:11
Bonjour,

Il faudrait avoir le message d'erreur ce serait plus simple pour trouver une solution.

Mais sinon il est possible que les paquets aient changé de nom. Vous pouvez essayez les commandes suivantes:
sudo apt-get install build-essential
sudo apt-get install qtcreator
sudo apt-get install qt5-default
Membre enregistré
39 messages
Posté le 11 juin 2021 - 09:40
Bonjour
Lors de l'exécution de l appli L'erreur générée :
La librairie QT version4.5 minimum est nécessaire
Le chargement de la DLL/home/alice/bureau/exe/wd240oj64.so a échoué
Le chargement de la DLL/home/alice/bureau/exe/wd240oj64.so a échoué

code erreur : 1065
Niveau : erreur fatale

message d'erreur système :
libQTgui.so.4 cannot open shared object file : No such file or directory
Dump de l'erreur du module 'wd240vn64.so'(24.0.205.2)
Identifiant des informations détaillées (.err): 1065
informations de débogage :
DLL qui provoque le chargement : WDVM

Lorsque je tape les commandes sur ubuntu
sudo apt-get install libqtcore5
sudo apt-get install libqtgui5
sudo apt-get install qt5-default
j ai
E: Impossible de trouver le paquet libqtcore5
E: Impossible de trouver le paquet libqtgui5
E: Impossible de trouver le paquet qt5-default

Merci
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 11 juin 2021 - 09:40
hello,

ALICE a écrit :
Bonjour je tente de développer une application pour linux .
Lorsque j'exécute l'application il me met erreur : la librairie QT version 4.5 minimum est necessaire

En ligne de commande j 'ai tapé :
sudo apt-get install libqtcore5
sudo apt-get install libqtgui5
Ca ne fonctionne pas

Avez vous une idée¿
Merci
Alice


Quelle version de windev as-tu ? et quelle version de Ubuntu ? Ubuntu en 64 bits ?

Ami calmant, J.P

--
Ami calmant, J.P
Membre enregistré
39 messages
Posté le 11 juin 2021 - 09:46
Bonjour
J ai une version 24 windev
version ubuntu-20.04.2.0- en 64 bits
Merci
Membre enregistré
39 messages
Posté le 11 juin 2021 - 10:01
Sur Raspberry c'est pareil
Membre enregistré
1 753 messages
Posté le 11 juin 2021 - 10:20
Déjà sur raspberry c'est un processeur ARM
Windev ne fonctionne que sur du X86
Sinon il faut faire une application java
Pour la lib qt, je ne sais pas.
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 11 juin 2021 - 10:27
hello,
ALICE a écrit :
Bonjour
Lors de l'exécution de l appli L'erreur générée :
La librairie QT version4.5 minimum est nécessaire
Le chargement de la DLL/home/alice/bureau/exe/wd240oj64.so a échoué
Le chargement de la DLL/home/alice/bureau/exe/wd240oj64.so a échoué

code erreur : 1065
Niveau : erreur fatale

message d'erreur système :
libQTgui.so.4 cannot open shared object file : No such file or directory
Dump de l'erreur du module 'wd240vn64.so'(24.0.205.2)
Identifiant des informations détaillées (.err): 1065
informations de débogage :
DLL qui provoque le chargement : WDVM

Lorsque je tape les commandes sur ubuntu
sudo apt-get install libqtcore5
sudo apt-get install libqtgui5
sudo apt-get install qt5-default
j ai
E: Impossible de trouver le paquet libqtcore5
E: Impossible de trouver le paquet libqtgui5
E: Impossible de trouver le paquet qt5-default

Merci


vu le message d'erreur que tu as il semblerait que la version 24 de windev utilise la version 4 de Qt (Qt4 à confirmer )
Quant au problème d'installation des paquets qt5, arrives-tu à installer d'autres types de paquets ?

--
Ami calmant, J.P
Membre enregistré
39 messages
Posté le 11 juin 2021 - 10:36
Ca ne fonctionne pas non plus avec la QT4
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 11 juin 2021 - 11:09
C'est l'installation de Qt4 qui ne fonctionne pas ?

--
Ami calmant, J.P
Membre enregistré
39 messages
Posté le 11 juin 2021 - 11:15
oui
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 11 juin 2021 - 11:54
Pour installet Qt4 sous Ubuntu 20.04 :

sudo add-apt-repository ppa:rock-core/qt4
sudo apt-get update
sudo apt-get install libqtcore4


--
Ami calmant, J.P
Membre enregistré
39 messages
Posté le 11 juin 2021 - 12:38
Pour la dernière commande j ai ce message :

Aucune version du paquet libqtcore4 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
qtchooser:i386 libqt5core5a:i386 qtchooser libqt5core5a

E: Le paquet « libqtcore4 » n'a pas de version susceptible d'être installée
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 11 juin 2021 - 12:53
tu peux essayer :
sudo apt install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui


--
Ami calmant, J.P
Membre enregistré
39 messages
Posté le 11 juin 2021 - 13:29
Impossible de trouver les paquets.
Membre enregistré
39 messages
Posté le 11 juin 2021 - 16:07
Ils ne proposent pas les téléchargements;
Ils proposent les lignes de commande et ça ne fonctionne pas
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 11 juin 2021 - 16:44
hello,
je viens d'essayer sous Ubuntu 20.04
Qt4 s'est installé avec la commande :
sudo apt-get install libqt4-dev


--
Ami calmant, J.P
Membre enregistré
1 753 messages
Posté le 11 juin 2021 - 17:06
Essais la commande de JP.
Si ça fonctionne pas
Mes liens propose un Binary Package
Exemple :
http://archive.ubuntu.com/ubuntu/pool/universe/q/qt4-x11/qt4-dev-tools_4.8.7+dfsg-7ubuntu1_amd64.deb
Membre enregistré
39 messages
Posté le 14 juin 2021 - 09:03
Bonjour
Je remercie tout le monde
la ligne de commande de Jurassic ne fonctionne pas
Pour la solution de popoy ça ne fonctionne pas non plus . J ai enregistre le fichier mais l installation est en attente.....Elle ne se lance pas
Membre enregistré
890 messages
Popularité : +13 (13 votes)
Posté le 14 juin 2021 - 09:32
hello,
que se passe-t-il exactement avec ma ligne de commande ? un message d'erreur ?
Lorsque tu tapes apt policy en ligne de commande as-tu des lignes concernant le dépôt rock-core qui s'affichent ?

--
Ami calmant, J.P
Membre enregistré
39 messages
Posté le 14 juin 2021 - 09:55
Bonjour
J'ai crée une machine virtuelle et les lignes de commandes fonctionnent
sudo add-apt-repository ppa:rock-core/qt4
sudo apt-get update
sudo apt-get install libqtcore4

Je vais tenter de reformater mon disque dur et réessayer
Membre enregistré
212 messages
Posté le 20 août 2021 - 19:11
Bonjour,

Avez vous trouvez une solution car j'ai exactement le même problème que vous ?
Membre enregistré
212 messages
Posté le 20 août 2021 - 19:22
sudo apt-get install libqtcore5 libqtgui5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libqtcore5
E: Impossible de trouver le paquet libqtgui5
Membre enregistré
212 messages
Posté le 20 août 2021 - 19:27
Auto réponse : Pour ma part , je viens de trouver ma bêtise.
j'ai transporté mon projet et il était encore sur ma clé USB ! ;( donc le system ne voulait rien savoir
une fois copié, j'ai pu dans les propriétés cochés "Autoriser l'execution du fichier comme un programme" et j'ai pu le lancer sans problème !