PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 26 → Windev 26 et signature depuis un windows 10 + tablette tactile
Windev 26 et signature depuis un windows 10 + tablette tactile
Débuté par Coban, 14 sep. 2021 12:53 - 3 réponses
Membre enregistré
11 messages
Posté le 14 septembre 2021 - 12:53
Bonjour à tous,

J'essaie de créer pour une application Windows 10 tactile un champ image pour que l'utilisateur puisse signer.

J'ai trouvé le code permettant de le faire mais je ne parviens pas à obtenir l'accés à l'option d'évènement "Bouton gauche relâché".

Je ne peux qu'ajouter l'option "Bouton gauche enfoncé".






Auriez vous déja rencontré ce problème ?

La docs en ligne semble pourtant laisser apparaitre ces options d'évènements... Est-ce qu'il y a une option propre au champ image à selectionner pour que cela soit disponible ?


Voici le code que j'ai trouvé sur un autre forum :

dans le code init de la fenetre
GLOBAL
VG_BoutonEnfonce est un booléen
VG_memoX, VG_memoY sont des entier

dans le code de l'image
// init du champs image
dDébutDessin(Image7)
dStylo(iNoir,0,2)

// bouton gauche enfonce
VG_BoutonEnfonce = Vrai
VG_memoX = SourisPosX()
VG_memoY = SourisPosY()

// bouton gauche relaché
VG_BoutonEnfonce = Faux

// survol souris (WM_MOVE)
SI VG_BoutonEnfonce ALORS
dLigne(VG_memoX,VG_memoY,SourisPosX(),SourisPosY())
VG_memoX = SourisPosX()
VG_memoY = SourisPosY()
FIN
MultitâcheRepeint()

// bouton enregistré
fichier est une chaîne
SI OUINON(0,"Sauver l'image ") = Oui ALORS
fichier = fSélecteur(fRepExe(),"","Sélection image","JPEG
(*.jpg)",".JPG",fselCrée)
SI fichier <> "" ALORS
dSauveImageJPEG(Image7,fichier)
SI ErreurDétectée ALORS ERREUR("Erreur durant la sauvegarde de l'image au
format JPEG",ErreurInfo())
FIN
FIN
Image7 = ""
dFinDessin(Image7)
dDébutDessin(Image7)
dStylo(iNoir,0,2)
Membre enregistré
2 628 messages
Posté le 14 septembre 2021 - 14:14
Bonjour,
l'évènement "bouton gauche relaché" est juste ne dessous de "bouton gauche enfoncé"

--
Il y a peut être plus simple, mais, ça tourne
Membre enregistré
11 messages
Posté le 15 septembre 2021 - 09:02
Bonjour Voroltinquo,

Merci pour ta réponse mais comme tu peux le voir dans ma capture d'écran il n y a rien sous "bouton gauche enfoncé".
Membre enregistré
11 messages
Posté le 15 septembre 2021 - 09:16
Chose étrange, aujourd'hui le champ est disponible....

Sujet clos en mode "mystère"...

Depuis hier j'ai simplement ajouté la configuration "Windows appli 64 bits" alors qu'hier il y avait seulement "Universal Windows 10 app"