PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 26 → Récupérer les nom des tables de mon projet par programmation
Récupérer les nom des tables de mon projet par programmation
Débuté par Testeur, 25 nov. 2021 17:27 - 4 réponses
Posté le 25 novembre 2021 - 17:27
Bonjour,
Je récupéré par programmation la liste des fenêtres de mon projet qui contient des table par la fonction EnumèreElément et EnumèreSousElément c'est ok
je vaudrais souhaité récupérer les nom des colonnes de ces table mais je n'arrive pas !
j'avais testé ce code d'aide de windev mais j'ai un message m'indique que ma table est inconnu .
UneColonne est un Champ
POUR nColonne = 1 _À_ TABLE_TableProduit.Occurrence(toColonne)
UneColonne <- TABLE_TableProduit.EnumèreColonne(nColonne)
Trace(UneColonne.NomComplet + "//" + UneColonne.Titre)
FIN


une piste si faisable stp
merci et bonne job
Membre enregistré
870 messages
Popularité : +2 (2 votes)
Posté le 25 novembre 2021 - 20:24
Bonjour,
Chez moi ça fonctionne.
Votre code se trouve bien dans la même fenêtre que la table qui est appelée ?
si ce n'est pas le cas il manque FEN_x.Table_TableProduit, me semble-t-il.

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube
Membre enregistré
27 messages
Posté le 26 novembre 2021 - 08:29
Bonjour

le code marche pour toi seulement si la fenetre est ouvert ?
je vaudrais dire je veux récupérer les nom des colonnes des tables.
je suis avec la version 23
merci de votre reponse
nb : on peut pas modifié le titre du message une fois validé ?

--
Yours mostafa
Membre enregistré
1 649 messages
Popularité : +9 (9 votes)
Posté le 26 novembre 2021 - 09:10
Bonjour,

Quel est le code complet de "Je récupéré par programmation la liste des fenêtres de mon projet qui contient des table par la fonction EnumèreElément et EnumèreSousElément" ?
Si le code présenté en est la suite, il devrait y avoir des indirections.

--
Bon dev,
Jean-Pierre
Posté le 26 novembre 2021 - 09:39
Bonjour
je récupère mes fenêtres avec les nom des tables mais pas encore les nom des colonnes des tables

NomFenêtre est une chaîne = EnumèreElément(enumFenêtre)

TANTQUE NomFenêtre <> ""

Nom_tbl = Fen_Tbl(NomFenêtre)

POUR TOUTE chaîne tblUN de Nom_tbl SEPAREE PAR RC

ind = TableAjouteLigne(TBL_TBL)

TBL_TBL[ind].COL_FEN = NomFenêtre
TBL_TBL[ind].COL_FEN..PoliceGras = Vrai
TBL_TBL[ind].COL_TBL = tblUN
FIN


NomFenêtre = EnumèreElément()
FIN


Procedure Fen_Tbl(NomFenêtre)

sNomChamp est une chaîne = EnumèreSousElément(NomFenêtre, enumPremier)

sNomComplet ,tbl_nom est une chaîne


TANTQUE sNomChamp <> ""

sNomComplet = NomFenêtre + "." + sNomChamp

SI {sNomComplet, indGPW}..Type = typTable _OU_ {sNomComplet, indGPW}..Type = typTableHierarchique ALORS

tbl_nom +=[RC]+sNomComplet

Fen_Tbl(sNomComplet) // ça marche pas l'énumération des colonnes de table
FIN

SI {sNomComplet, indGPW}..Type = typColonne ALORS
Trace("colo : "+sNomComplet)
FIN


sNomChamp = EnumèreSousElément(NomFenêtre)
FIN

RENVOYER tbl_nom



MErci