PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile (précédentes versions) → iImprimeimage n'affiche rien sur tablette
iImprimeimage n'affiche rien sur tablette
Débuté par Traine, 20 jan. 2017 14:02 - Aucune réponse
//hostimage.webdev.info/avatars/xovZBVd2vzjYEPA7Sg2eA
Membre enregistré
2 messages
Posté le 20 janvier 2017 - 14:02
Bonjour,

je suis sur WinDev mobile 20.

je créer un PDF avec les fonctions iImprime pour Android. Lorsque je créé mon PDF sur le simulateur il m'affiche aussi bien les saisies que les images (image créer sur l'application par l'utilisateur mode stylet, dessins fait à main levée).

Par contre lorsque je porte l'application sur la tablette (Galaxy note 10.1 version 2014), Elle fonctionne très bien, la saisie les dessins .... mais dès que je créé mon PDF tout s'affiche sauf le dessin.

quand je retourne sur dans l'application sur ma tablette et que j'affiche la page ou le dessin à été créé il est bien présent.

Voici le code utiliser pour créer mon PDF


Nompdf est une chaîne = FEN_Repère_SAUV.SAI_NumChantier + FEN_Repère_SAUV.SAI_Repère


iDestination(iPDFGénérique, ComplèteRep(SysRepCarteStockage()) + Nompdf +".pdf")

iImprime(iPolice(3)+iPosY(15)+iPosX(5)+"Numchantier : "+ FEN_Repère_SAUV.SAI_NumChantier);
iImprime(iPolice(3)+iPosY(15)+iPosX(40)+"Nomchantier : "+ FEN_Repère_SAUV.SAI_NomChantier);
iImprime(iPolice(3)+iPosY(15)+iPosX(90)+"Repère : "+ FEN_Repère_SAUV.SAI_Repère);
iImprime(iPolice(3)+iPosY(15)+iPosX(140)+"Type châssis : "+ FEN_Repère_SAUV.SAI_TypeChâssis);
iImprime(iPolice(3)+iPosY(30)+iPosX(5)+"Couleur Int : "+ FEN_Repère_SAUV.SAI_CouleurInt);
iImprime(iPolice(3)+iPosY(30)+iPosX(55)+"Couleur ext : "+ FEN_Repère_SAUV.SAI_Couleurext);
iImprime(iPolice(3)+iPosY(30)+iPosX(110)+"Vitrage : "+ FEN_Repère_SAUV.SAI_Vitrage);
iImprime(iPolice(3)+iPosY(30)+iPosX(175)+"HP : "+ FEN_Repère_SAUV.SAI_HP);
iImprime(iPolice(3)+iPosY(45)+iPosX(5)+"Qté : "+ FEN_Repère_SAUV.SAI_Qté);
iImprime(iPolice(3)+iPosY(45)+iPosX(35)+"Sens d'ouv. : "+ FEN_Repère_SAUV.COMBO_Sensouverture..ValeurAffichée);
iImprime(iPolice(3)+iPosY(45)+iPosX(110)+"vue : "+ FEN_Repère_SAUV.COMBO_Vue..ValeurAffichée);
iImprime(iPolice(3)+iPosY(60)+iPosX(5)+"Largeur : "+ FEN_Repère_SAUV.SAI_Largeur);
iImprime(iPolice(3)+iPosY(60)+iPosX(40)+"Hauteur : "+ FEN_Repère_SAUV.SAI_Hauteur);
iImprime(iPolice(3)+iPosY(60)+iPosX(80)+"Mode de pose : "+ FEN_Repère_SAUV.COMBO_Modepose..ValeurAffichée);
iImprimeImage(FEN_Repère_SAUV.IMG_Image,5, 75,200, 155,iAffichageNormal)
iImprime(iPolice(3)+iPosY(165)+iPosX(5)+"Commentaire : ");
iImprime(iPolice(3)+iPosY(170)+iPosX(5)+ FEN_Repère_SAUV.SAI_Com);

iFinImprime();


LanceAppliAssociée(Nompdf+".pdf");



quelqu'un aurait un idée d'ou ça peut venir?

cordialement