PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile (précédentes versions) → [WM21]Charger un pdf sur une Application Android
[WM21]Charger un pdf sur une Application Android
Débuté par Stéphanie, 12 avr. 2017 15:08 - Aucune réponse
Membre enregistré
8 messages
Posté le 12 avril 2017 - 15:08
Bonjour,
Je réalise une application qui permet en outre à un utilisateur d'envoyer des photos ou un document.
J'arrive à importer et afficher une photo de la galerie ou prise à partir de l'application, photo qui est affichée dans une Image, mais concernant un document pdf, rien n'y fait. Je souhaite en effet que l'utilisateur puisse aller chercher dans son gestionnaire de fichier un document, pour au moins récupérer le chemin du fichier pdf (dans le cas le moins optimal) et au mieux que je puisse l'afficher dans l'application.

Merci d'avance !

Le code :
// Contient le chemin de l'image
fichierImage est une chaîne
bAnnule est un booléen = True



SELON Dialogue("Sélectionnez un document")
// Prendre une photo
CAS 1
fichierImage = VidéoLanceAppli(viCaptureImage)
SI fichierImage = "" ALORS
SI ErreurInfo()<>"" ALORS
Erreur("Impossible de prendre une photo.", ErreurInfo())
FIN
RETOUR
SINON // Si pas d'erreur, on pourra stocker et afficher l'image
bAnnule = False
FIN
// Choisir une image
CAS 2
fichierImage = AlbumSélecteur(albumImage)
SI fichierImage = "" ALORS
SI ErreurInfo()<>"" ALORS
Erreur("Impossible de sélectionner une photo.", ErreurInfo())
FIN
RETOUR
SINON// Si pas d'erreur, on pourra stocker et afficher l'image
bAnnule = False
FIN

// Annuler
CAS 3

FIN

SI PAS bAnnule ALORS
Img est une Image


sInfoImage est une chaîne = InfoBitmap(fichierImage)
nLargeur est un entier = Val(ExtraitChaîne(sInfoImage, 2))
nHauteur est un entier = Val(ExtraitChaîne(sInfoImage, 3))

Img = fichierImage

// Les images sont stockées dans un tableau de buffer, pour qu'elles puissent être renvoyés via un web service
TableauAjoute(tableau_buffImg,dSauveImageJPEG(Img,enMémoire,50))
ZoneRépétéeInsèreLigne(ZR_Document,0,Img,1) // Zone Répétée qui affiche toutes nos images
FIN