PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile (précédentes versions) → [WM21] Connexion FTP Android
[WM21] Connexion FTP Android
Débuté par Wahib, 11 mai 2017 10:39 - 1 réponse
//hostimage.webdev.info/avatars/bbgSOZ3jr8FaEwGKdcK7Q
Membre enregistré
35 messages
Posté le 11 mai 2017 - 10:39
Bonjour à tous,

Dans mon application, je dois me connecter à un FTP pour récupérer des fichiers.
Cette connexion fonctionne parfaitement sur un programme windows, ou même un device sous windows CE mais je n'y arrive pas en Android.

gnIdConnexion est un entier = -1
gnIdConnexion=FTPConnecte("monftp","user","pass",port,Vrai)
SI PAS gnIdConnexion=-1 ALORS
//Traitements
FTPDéconnecte(gnIdConnexion)
SINON
Erreur("Connexion FTP : "+ErreurInfo())
FIN


Et je reçois le message d'erreur suivant : "Echec de la connexion au serveur FTP xxxx sur le port xx avec le nom d'utilisateur xxxx"

Quelqu'un sait pourquoi j'ai ce message? Il y a une façon différente de faire sur Android?
Merci d'avance
//hostimage.webdev.info/avatars/default.gif
Posté le 11 mai 2017 - 14:31
Bonjour Wahib

sous android, par défaut les chaines sont unicode... dans les autres cas
cités, elles sont ANSI

Donc, quand tu fais "FTPConnecte("monftp","user","pass",..."
tu utilises des chaines unicode la ou serveur attend de l'ansi

Déclare des chaines ansi et utilise les à la place et ca devrait fonctionner

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

A votre disposition : WXShowroom.com, WXReplication (open source) et
maintenant WXEDM (open source)

Plus d'information sur http://fabriceharari.com


Le 5/11/2017 à 2:39 AM, Wahib a écrit :
Bonjour à tous,

Dans mon application, je dois me connecter à un FTP pour récupérer des
fichiers.
Cette connexion fonctionne parfaitement sur un programme windows, ou
même un device sous windows CE mais je n'y arrive pas en Android.

gnIdConnexion est un entier = -1
gnIdConnexion=FTPConnecte("monftp","user","pass",port,Vrai)
SI PAS gnIdConnexion=-1 ALORS
//Traitements
FTPDéconnecte(gnIdConnexion)
SINON
Erreur("Connexion FTP : "+ErreurInfo())
FIN


Et je reçois le message d'erreur suivant : "Echec de la connexion au
serveur FTP xxxx sur le port xx avec le nom d'utilisateur xxxx"

Quelqu'un sait pourquoi j'ai ce message? Il y a une façon différente de
faire sur Android?
Merci d'avance