PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 24 → Table qui fonctionne sous l'émulateur Windev mobile mais pas sur un mobile Android
Table qui fonctionne sous l'émulateur Windev mobile mais pas sur un mobile Android
Débuté par Maxime Vauchel, 01 juin 2015 16:09 - 6 réponses
Posté le 01 juin 2015 - 16:09
Bonjour,
Je me permets de vous écrire car je suis toujours dans l'impasse après avoir retourné le problème dans tous les sens sans succès.
Pour introduire, mon objectif était de modifier une application existante qui affichait une table codée en html (le champ table n'étant pas disponible pour Android et IOS avant la version 20) pour qu'elle affiche une table avec le champ table maintenant disponible.
J'y suis parvenu, tout fonctionne correctement avec l'émulateur Windev, seulement quand j'ai voulu l'installer sur un mobile android, problème en voulant afficher ma table :"Erreur dans le traitement de FEN_Tableau_HTML. L'opérateur [] est incompatible avec le type ligne de zone répétée."

Après avoir commenté étapes par étapes les différentes parties de mon code, j'en suis arrivé au fait que mon erreur venait de cette partie de code:
POUR i = 1 A (gNbLignesTableau)

//on insère le contenu de gtabMonTab dans la table de FEN_Tableau
TableAjouteLigne(TABLE_Tableau,gtabMonTab[i,1],gtabMonTab[i,2],gtabMonTab[i,3],gtabMonTab[i,4],gtabMonTab[i,5],gtabMonTab[i,6],gtabMonTab[i,7])
SI bAfficherLaLigne=Vrai ALORS
POUR j=1 A (gNbColonnesTableau)
SI i=1 ALORS
//Titre des colones par défaut en fond blanc et texte noir
TABLE_Tableau[1]..CouleurFond = Blanc
TABLE_Tableau[1]..Couleur = Noir
SINON
SI i = 2 ALORS
sCouleur=GrisFoncé
FIN
SI i=3 ALORS
sCouleur=RVB(0,179,255)
FIN
SI i =4 ALORS
sCouleur=Noir
FIN
SI j=2 ALORS//Colonne diametre
SI Val(gtabMonTab[i,j]) = rDextMin ALORS
sCouleur=VertFoncé
SINON SI Val(gtabMonTab[i,j]) = rDextMax ALORS
sCouleur=RougeClair
SINON
sCouleur=RVB(255,153,0)
FIN
SINON SI j = 4 ALORS // colonne vitesse
SI Arrondi(Val(gtabMonTab[i,j]),2)<0.5 OU Arrondi(Val(gtabMonTab[i,j]),2) > 2 ALORS
sCouleur=RougeClair
FIN
SINON SI j = 7 // colonne Coup de bélier
SI Arrondi(Val(gtabMonTab[i,j]),2) > 10 ALORS
sCouleur=RougeClair
FIN
FIN
SI j = 2 ALORS
TABLE_Tableau[i][j]..CouleurFond= sCouleur
TABLE_Tableau[i][j]..Couleur= Blanc
SINON SI j < 4
TABLE_Tableau[i][j]..CouleurFond= sCouleur
TABLE_Tableau[i][j]..Couleur= Blanc
SINON
TABLE_Tableau[i][j]..CouleurFond= sCouleur
TABLE_Tableau[i][j]..Couleur= Blanc
FIN
FIN
FIN
FIN
//On recherche si l'utilisateur veut afficher PE100, s'il ne veut pas on supprime la ligne
SI Contient(TABLE_Tableau[i][1],"PE100") ET ListeSelect(FEN_Principale.COMBO_Affichage_PE)=2 ALORS
nResultat est un entier
nResultat = TableCherche(COL_SansNom1,"PE100",Faux,1)
TableSelectPlus(TABLE_Tableau,nResultat)
TableSupprime(TABLE_Tableau)
bAfficherLaLigne=Faux
FIN
FIN


Ce code permet dans un premier lieu d'ajouter les valeurs d'un tableau de chaines dans la table, ensuite de définir des couleurs pour les 4 lignes qu'il contient et ensuite de modifier les couleurs de certaines cellules. Enfin le dernier SI sert a afficher ou non la dernière ligne du tableau.
Ce code fonctionne très bien sur l'émulateur Windev, mais quand je génère l'application sur mon mobile et que j'essaye d'afficher ma table j'obtient le message d'erreur : "Erreur dans le traitement de FEN_Tableau_HTML. L'opérateur [] est incompatible avec le type ligne de zone répétée."
gtabMonTab est un tableau de chaines contenant les valeurs des champs a affecter a Table_Tableau, en commentant tout le reste cela fonctionne bien sur le mobile. C'est après que ça coince.

Voila je vous remercie a l'avance, en espérant avoir été assez clair, sinon je suis disponible pour donner plus de précisions.
Merci.
Posté le 02 juin 2015 - 08:59
Bonjour,
J'ai peut être une piste, j'ai essayé de commenter toutes les lignes ou on utilisait Table_Tableau[i][j] et je vois que sans ces lignes le tableau s’exécute et ne renvoie pas d'erreur, par contre je n'ai plus mes couleurs ni ma suppression de ligne.
Est ce que quelqu'un sait pourquoi ce n'est pas possible d'utiliser Table_Tableau de cette façon en Android ?
Merci.
Posté le 02 juin 2015 - 14:02
Bonjour Maxime

je dirais parceque le controle table VIENT d'apparaitre en 20 sur
android et ne supporte pas encore tout ce que supporte le même controle
sous windev... Et comme l'émulateur est écrit en windev...

A signaler au support

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

Disponible : WXShowroom.com, WXReplication (open source)
Bientôt : WXEDM (open source)
Plus d'information sur http://fabriceharari.com


On 6/2/2015 12:59 AM, Maxime Vauchel wrote:
Bonjour,
J'ai peut être une piste, j'ai essayé de commenter toutes les lignes ou
on utilisait Table_Tableau[i][j] et je vois que sans ces lignes le
tableau s’exécute et ne renvoie pas d'erreur, par contre je n'ai plus
mes couleurs ni ma suppression de ligne.
Est ce que quelqu'un sait pourquoi ce n'est pas possible d'utiliser
Table_Tableau de cette façon en Android ?
Merci.
Posté le 02 juin 2015 - 16:03
Bonjour Fabrice,
C'est ce que je me suis dit aussi.
J'essaye de contourner le problème comme je peux pour ne pas utiliser table_tableau[i][j].
Merci de m'avoir répondu.
Cordialement


Fabrice Harari a écrit :
Bonjour Maxime

je dirais parceque le controle table VIENT d'apparaitre en 20 sur
android et ne supporte pas encore tout ce que supporte le même controle
sous windev... Et comme l'émulateur est écrit en windev...

A signaler au support

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

Disponible : WXShowroom.com, WXReplication (open source)
Bientôt : WXEDM (open source)
Plus d'information sur http://fabriceharari.com


On 6/2/2015 12:59 AM, Maxime Vauchel wrote:
Bonjour,
J'ai peut être une piste, j'ai essayé de commenter toutes les lignes ou
on utilisait Table_Tableau[i][j] et je vois que sans ces lignes le
tableau s’exécute et ne renvoie pas d'erreur, par contre je n'ai plus
mes couleurs ni ma suppression de ligne.
Est ce que quelqu'un sait pourquoi ce n'est pas possible d'utiliser
Table_Tableau de cette façon en Android ?
Merci.
Posté le 21 décembre 2017 - 19:35
toujours le même problème en v23...
support technique, il faudrait peut-être faire quelque choses ??
Posté le 15 avril 2019 - 19:40
Bonjour
As-tu résolu ton problème depuis?
Membre enregistré
271 messages
Posté le 16 avril 2019 - 06:56
C'est pas parce que un champ existe, qu'il faut l'utiliser.
perso, au vu des nombreux bugs des tables.
j'utilise une ZR ou ZM ou une table en HTML.
J'utilise aussi mes propres champs agenda.
J'utilise aussi mon propre champ saisie HTML ou Galerie.
Je suis pourtant en 23, mais j'ai pas le temps a perdre de debuger des éléments dont j'ai pas les sources.
Mes clients doivent être livrer.
Donc faites vos propres champs.