PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → Probleme du champs ,ma carte est centrée toujours vers paris
Probleme du champs ,ma carte est centrée toujours vers paris
Débuté par obambi patience, 19 fév. 2016 23:52 - 5 réponses
Posté le 19 février 2016 - 23:52
Bonjour je developpe une application qui utilise le champs carte de windev mobile, sur le simulateur de windev lorsque je met sur libreville(gabon) le simulateur m'affiche l'adresse sur la carte cependant lorsque je génère l'apk et je l'installe sur mon téléphone la carte est centrér maintenant sur paris. voici le code :

///Code d'initialisation du champ carte :
// Est-ce-que le GPS est actif ?
SI GPSEtat() <> gpsActivé ALORS
Erreur("Le GPS n'est pas en état de fonctionner.", ...
"Veuillez l'activer pour avoir accès à cette application.")
RETOUR
FIN

sMonAdr est une chaîne
marque est un Marqueur
geopos est une géoPosition
sMonAdr = "IAI 2263 Libreville"
CarteAffichePosition(CARTE_RESTO,sMonAdr)
CARTE_RESTO..Zoom = 14
geopos=CarteRécupèrePosition(CARTE_RESTO)
marque.Position=geopos
CarteAjouteMarqueur(CARTE_RESTO,marque)

aidez moi c'est urgent

Cordialement !
Membre enregistré
130 messages
Popularité : +1 (1 vote)
Posté le 22 février 2016 - 16:30
Bonjour,
C'est le facteur de zoom qui pose problème (c'est un piège) : changez le zoom AVANT de faire le carteAffichePosition et JAMAIS après !

Bon dev
Samir BOUCHETIBAT
Membre enregistré
39 messages
Popularité : +1 (1 vote)
Posté le 22 février 2016 - 17:59
J'ai exactement le même problème

/ initialisation position mairie
gMaPositionMairie est une géoPosition
gMaPositionMairie..Latitude = 47.792039
gMaPositionMairie..Longitude= 2.932381
CARTE_GoogleCommune..ModeCarte = carteModePlan
CARTE_GoogleCommune..Valeur = gMaPositionMairie
CARTE_GoogleCommune..Zoom = 16
CarteAffichePosition(CARTE_GoogleCommune,gMaPositionMairie)

En VM 20, tout fonctionne.
J'envoie un CR au service technique PC soft.

--
JGV
Membre enregistré
39 messages
Popularité : +1 (1 vote)
Posté le 22 février 2016 - 23:00
J'ai refait quelques tests : sur android version 4 at plus c'est bon; sur android 5; ca bug; eaayer votre appli dur un téléphone android 4 et plus (pas 5 ni suivant). Cordialement. JGV

--
JGV
Posté le 27 septembre 2018 - 15:38
Bonjour

J'ai le même problème en webdev 22 PHP .
J'initialise bien d'abord le zoom mais rien n'y fait. En mode simulateur, j'ai bien ma carte centrée sur la bonne ville (Toulouse en l'occurrence) et mes marqueurs s'affichent. En revanche, en mode production sur un serveur apache/php, la carte est centrée sur Paris et les marqueurs ne s'affichent pas.

Je précise que j'ai une clé de production Google (payante).

Votre avis serait utile.

Merci
Laurent
Posté le 30 septembre 2018 - 07:34
Avez vous vérifier le paramétrage du fuseau horaire de l'appareil ?
Parfois lorsqu'il est automatique il peut selon l'appareil se mettre sur la Belgique, la France etc.
En le forçant, cela règle le problème (pas faisable sur tous les appareils)