PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 22 → Installation Android support library v4
Installation Android support library v4
Débuté par Nirina Mampiandrasoa, 25 déc. 2016 00:34 - 14 réponses
//hostimage.webdev.info/avatars/EGILeCf44k92S5MCQPpclg
Membre enregistré
3 messages
Posté le 25 décembre 2016 - 00:34
Bonjour tout le monde. J'ai un petit soucis avec windev mobile 20. Impossible de trouvé "android support library". Ce composant ne figure plus dans le SDK, pourtant j'ai installé "Android support ripository" et "Google Repository" mais ça ne résolut pas mon problème.
Dorenavant, j'ai utilisé windows 7 et tout marche bien mais avec windows 10, ça ne marche plus. Merci de votre aide !
Cordialement,
//hostimage.webdev.info/avatars/default.gif
Posté le 26 décembre 2016 - 14:15
Bonjour

souvent, dans ce genre de cas, il faut cocher la cache qui permet
d'afficher les composants obsolètes, en bas de la fenêtre, et ce qu'on
cherche apparait...

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

A votre disposition : WXShowroom.com, WXReplication (open source) et
maintenant WXEDM (open source)

Plus d'information sur http://fabriceharari.com


Le 12/24/2016 à 6:34 PM, Nirina Mampiandrasoa a écrit :
Bonjour tout le monde. J'ai un petit soucis avec windev mobile 20.
Impossible de trouvé "android support library". Ce composant ne figure
plus dans le SDK, pourtant j'ai installé "Android support ripository" et
"Google Repository" mais ça ne résolut pas mon problème.
Dorenavant, j'ai utilisé windows 7 et tout marche bien mais avec windows
10, ça ne marche plus. Merci de votre aide !
Cordialement,
//hostimage.webdev.info/avatars/EGILeCf44k92S5MCQPpclg
Membre enregistré
3 messages
Posté le 26 décembre 2016 - 17:52
J'avais déjà fait beaucoup de manipulation mais le problème persiste toujours. Cochez sur la case obsolète, installation manuelle par ligne de commande, réinstallation de l'SDK, etc, mais aucun résultat !!!
//hostimage.webdev.info/avatars/384GgB4ahdbQbxdRHXazQ
Membre enregistré
625 messages
Popularité : +13 (13 votes)
Posté le 26 décembre 2016 - 23:56
hello,
le problème c'est que dans les nouveaux SDK android il n'y a plus de Android support library mais le Android support repository qui est un dépot de librairies maven utilisé par gradle . Gradle a été introduit par PCSOFT à partir de la version 21 de windev mobile (à ma connaissance). Donc dans les versions avant la 21, il fallait avoir le Android support library pour pouvoir générer une appli android avec le mode de compatibilité d'anciennes API.
Voici ce que vous pouvez faire pour faire réapparaître le Android support library dans le SDK .
1 - Se positionner dans le répertoire du SDK utilisé et vérifier ce qu'il y a dans le répertoire extras\android





dans les nouveaux SDK il n'y a plus que m2repository ce qui correspond au dépôt local maven pour gradle.

2 - Allez sur la page suivante et télécharger le Android Support Library (essayer la dernière révision)
http://androidtoolsofflinedownload.blogspot.fr/p/download-android-support-library-offline.html

3 - Dézipper le fichier téléchargé dans le répertoire extras\android du sdk, Vous devriez vous retrouvez avec quelque chose comme ceci :






4 - Et oh miracle le Android support library est de retour dans le SDK manager.





Comme je n'ai pas pu essayer cette manipulation sur une version windev mobile < 21, à vous de me dire si la génération android fonctionne.

--
Ami calmant, J.P
Message modifié, 27 décembre 2016 - 00:00
//hostimage.webdev.info/avatars/default.gif
Posté le 06 janvier 2017 - 09:49
ca marche nickel sur Windev 20

Merci !
//hostimage.webdev.info/avatars/default.gif
Posté le 07 janvier 2017 - 13:21
Tres grang merci mon Frere... tu m'as sauvé la vie :merci:
//hostimage.webdev.info/avatars/i1BAqKW68Dmc4bC46m5Aw
Membre enregistré
10 messages
Popularité : +1 (1 vote)
Posté le 26 janvier 2017 - 19:10
Jurassic Pork, grand merci pour ta contribution !
car dépuis la création de windev mobil, je n'ai jamais pu générer un apk. Avec la version windev 20, j'ai failli tout laisser tomber ;(a cause de cette erreur mais heureusement qu'il y toujours quelqu'un comme toi nous montrer comment résoudre le problème simplement !
Encore, grand merci à toi ! :merci:
//hostimage.webdev.info/avatars/default.gif
Posté le 03 février 2017 - 10:54
Thanks a lot ! you saved my life :)
//hostimage.webdev.info/avatars/default.gif
Posté le 04 mars 2017 - 00:56
perso, je n'y arrive pas, j'ai tout essayé depuis des années, et à chaque fois il y a tjs qq chose qui m'empêche de faire fonctionner la plateforme. Là, c'est cette extension "extras" introuvable, mais maintenant j'en ai marre, trop de temps perdu et aucune perspective d'un truc stable qui me permette de me lancer dans un développement sous android. Autant continuer de boursicoter, on devient riche bien plus vite qu'en faisant des applis, même géniales.

La génération a échoué.
L'extension (extras) Google Repository n'a pas été trouvée.
Elle est nécessaire pour générer l'application avec Gradle.
//hostimage.webdev.info/avatars/default.gif
Posté le 04 mars 2017 - 01:05
bravo, j'ai désinstallé la v20 qui ne marchait pas; les apk étaient générés et s'installaient sur les mobiles, mais tous les contenus étaient vides ou bien incapables de démarrer.
J'ai installé la v21, mais après un plantage de l'appli, et compris que l'installation auto n'installait pas le gradle, j'ai tenté l'install manuelle, mais là c'est le zip qui est incomplet et qui n'a pas l'extension...
et en fait on se rend compte que tout ce truc ultra-prometteur ne marche que pour une minorité de développeurs chanceux et ultra courageux... ca doit pas dépasser 1% de tous ceux qui ont tenté de tester cette plateforme.
Je pourrai chercher davantage, mais j'ai perdu patience, car au final je me dis que l'appli risque d'être nulle, vu que toutes ces difficultés de bases n'ont pas pu être résolues... alors quoi espérer de la plateforme ?
Quand je pense que j'ai été formé 6 mois à Windev via l'Apec il y a 13 ans... tout ca pour rien.
//hostimage.webdev.info/avatars/default.gif
Posté le 04 mars 2017 - 16:39
La, je ne sais pas s'il faut rire ou pleurer

TU n'y arrives pas, et donc 99% de gens qui essayent n'y arrivent pas ?

Wow... Ca c'est de la remise en question

Le 3/3/2017 à 7:05 PM, Eric a écrit :
bravo, j'ai désinstallé la v20 qui ne marchait pas; les apk étaient
générés et s'installaient sur les mobiles, mais tous les contenus
étaient vides ou bien incapables de démarrer.
J'ai installé la v21, mais après un plantage de l'appli, et compris que
l'installation auto n'installait pas le gradle, j'ai tenté l'install
manuelle, mais là c'est le zip qui est incomplet et qui n'a pas
l'extension...
et en fait on se rend compte que tout ce truc ultra-prometteur ne marche
que pour une minorité de développeurs chanceux et ultra courageux... ca
doit pas dépasser 1% de tous ceux qui ont tenté de tester cette plateforme.
Je pourrai chercher davantage, mais j'ai perdu patience, car au final je
me dis que l'appli risque d'être nulle, vu que toutes ces difficultés de
bases n'ont pas pu être résolues... alors quoi espérer de la plateforme ?
Quand je pense que j'ai été formé 6 mois à Windev via l'Apec il y a 13
ans... tout ca pour rien.
//hostimage.webdev.info/avatars/i1BAqKW68Dmc4bC46m5Aw
Membre enregistré
10 messages
Popularité : +1 (1 vote)
Posté le 04 mars 2017 - 23:53
Bsr Eric as tu installé :
1- le SDK d'android ?
2- Android Support Library (http://androidtoolsofflinedownload.blogspot.fr/p/download-android-support-library-offline.html) ??
//hostimage.webdev.info/avatars/default.gif
Posté le 16 mars 2017 - 03:52
Vraiment merci bcp de nous avoir sauvé la vie. Longue vie à vous
//hostimage.webdev.info/avatars/default.gif
Posté le 18 avril 2017 - 10:43
Merci beaucoup Jurassic Pork, tu me sauve je t'assure.
je viens de débuter avec le développement android dans Windev Mobile et je n'arrivais pas a générer l'apk. Mon pb est désormais résolu. Merci beaucoup
//hostimage.webdev.info/avatars/default.gif
Posté le 24 juin 2017 - 03:02
pour moi, j'ai essayé ts mais tjs le même problème. je pense qu'il faut aller a la version 21 ou + ....