PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 22 → Notification Push IOS (Erreur bizarre : Le nom CN du certificat ne correspond pas à la valeur passée)
Notification Push IOS (Erreur bizarre : Le nom CN du certificat ne correspond pas à la valeur passée)
Débuté par Jennifer, 06 mai 2017 17:30 - 5 réponses
//hostimage.webdev.info/avatars/dUKdE29l0tYWi5tsX27JUQ
Membre enregistré
59 messages
Posté le 06 mai 2017 - 17:30
Bonjour,

J'ai fait tout le NET dans l'espoir de trouver une solution à mon problème.
J'ai suivi scrupuleusement la procédure pour mettre en place une application (serveur) de notification Push, sur Android tout est parfait, sur IOS c'est l'horreur...

J'ai donc fait la procédure suivante :
https://doc.pcsoft.fr/?1000021032

Tout est ok, mais quand je souhaite juste faire :

// Variables
tabTokensInvalides est un tableau de Buffers
tabMoncertif est un tableau de Certificat
sToast est une chaîne

Sablier(Vrai)

// Chargement du certificat
tabMoncertif = CertificatCharge("D:\Mes Projets\ServeurPush\Exe\CertificatIOS\Certificats.p12","123123")
Trace(tabMoncertif..Occurrence)
Trace(ErreurDétectée)
Trace(ErreurInfo)

// Récupère les tokens
tabTokensInvalides = NotifPushListeIdentifiantsInvalides(tabMoncertif[1],typeServiceIOSTest)

// On traite les tokens invalides
SI tabTokensInvalides..Occurrence > 0 ALORS
// On supprime les tokens invalides
FIN

// Toast indiquant le résultat
SI tabTokensInvalides..Occurrence > 1 ALORS
sToast = ChaîneConstruit("%1 tokens invalides supprimés",tabTokensInvalides..Occurrence)
SINON
sToast = ChaîneConstruit("%1 token invalide supprimé",tabTokensInvalides..Occurrence)
FIN
ToastAffiche(sToast)

Sablier(Faux)

CAS ERREUR:
Trace("ERREUR",ErreurInfo())


J'ai un message d'erreur à la toute fin

ERREUR Des erreurs de sécurité ont été détectées pendant la mise en place de la communication<\r><\n>Détail de l'erreur système : Le nom CN du certificat ne correspond pas à la valeur passée.<\r><\n>


J'avais un contrat assistance directe, qui m'informe :

Ce message signifie que le nom du serveur dans le certificat ne corresponde pas à l'adresse du serveur utilisé. Cela peut-être par exemple le cas si vous utilisez le certificat de test avec le serveur de production ou inversement.


Bennn ... je suis blonde ok, mais j'ai refait 10 fois les tests, j'ai toujours ce message ... Alors SVP aidez moi ! ='( PLEASEEEEEEEEEEEEEEEEEEEEEEUH

Merci d'avance :)
//hostimage.webdev.info/avatars/dUKdE29l0tYWi5tsX27JUQ
Membre enregistré
59 messages
Posté le 12 mai 2017 - 02:43
Petit UP svp :(
//hostimage.webdev.info/avatars/Ib6ZLrgBblQaFZU7pB2Dg
Membre enregistré
448 messages
Popularité : +1 (1 vote)
Posté le 12 mai 2017 - 09:09
Bonjour,

Sans certitude mais j'ai l'impression que ton certificat n'est tout simplement pas chargé...

tabMoncertif = CertificatCharge("D:\Mes Projets\ServeurPush\Exe\CertificatIOS\Certificats.p12","123123")

Ta procédure d'envoi du push est sur un serveur j'imagine ? Es-tu sure du chemin ?
Aussi, as-tu vérifié ce que contient le tableau après CertificatCharge ?

Le cas échéant, essaye plutôt la syntaxe suivante pour charger le certificat (plutôt que le chemin en dur) :
cerMonCertificat = CertificatCharge(fRepDonnées() + [fSep] + "TonCertif.p12", "TonPwd")

Pour ma part, cela fonctionne chez moi et le certificat est installé sur un serveur de chez pcscloud.

Cdlt - Eric.

--
Eric DELATTRE
http://www.yoosite.fr
Message modifié, 12 mai 2017 - 09:10
//hostimage.webdev.info/avatars/dUKdE29l0tYWi5tsX27JUQ
Membre enregistré
59 messages
Posté le 12 mai 2017 - 15:30
Bonjour,

Je te remercie pour ta réponse !!! :)

J'ai changé le code
// Variables
tabTokensInvalides est un tableau de Buffers
tabMoncertif est un tableau de Certificat
sToast est une chaîne

Sablier(Vrai)

// Chargement du certificat
tabMoncertif = CertificatCharge(fRepDonnées() + [fSep] + "Certificat_dev.p12", "123123")

Trace(tabMoncertif..Occurrence)
Trace(ErreurDétectée)
Trace(ErreurInfo)

// Récupère les tokens
tabTokensInvalides = NotifPushListeIdentifiantsInvalides(tabMoncertif[1],typeServiceIOSTest)

// On traite les tokens invalides
SI tabTokensInvalides..Occurrence > 0 ALORS
// On supprime les tokens invalides
FIN

// Toast indiquant le résultat
SI tabTokensInvalides..Occurrence > 1 ALORS
sToast = ChaîneConstruit("%1 tokens invalides supprimés",tabTokensInvalides..Occurrence)
SINON
sToast = ChaîneConstruit("%1 token invalide supprimé",tabTokensInvalides..Occurrence)
FIN
ToastAffiche(sToast)

Sablier(Faux)

CAS ERREUR:
Trace("ERREUR",ErreurInfo())


Afin de me calquer à ce que tu as fais, mais le résultat reste le meme ....
Toujours à cette ligne " tabTokensInvalides = NotifPushListeIdentifiantsInvalides(tabMoncertif[1],typeServiceIOSTest) "

Pourtant le certificat est bien chargé
(cf. image debug :) https://drive.google.com/open…


Des erreurs de sécurité ont été détectées pendant la mise en place de la communication
Détail de l'erreur système : Le nom CN du certificat ne correspond pas à la valeur passée.


Je suis vraiment perdue ='(
//hostimage.webdev.info/avatars/dUKdE29l0tYWi5tsX27JUQ
Membre enregistré
59 messages
Posté le 13 mai 2017 - 19:24
Petit UP SVP, personne n'a jamais été confronté à ce problème ?
//hostimage.webdev.info/avatars/default.gif
Posté le 05 juillet 2017 - 15:50
Bonjour,

Avez-vous trouvé une solution à votre problème?

J'ai le même soucis, et je ne vois pas trop comment le résoudre.


Cordialement,
Rudy Rousseau