PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 22 → Deserialisation psdXML
Deserialisation psdXML
Débuté par Fred-SQS, 17 mai 2017 08:56 - Aucune réponse
Membre enregistré
16 messages
Posté le 17 mai 2017 - 08:56
Bonjour,

Je suis en train de développer une application mobile qui affiche une liste d'ingrédients dans une fenêtre. Pour cela je fais appel à un WebService fait en Windev.
Mon problème est le suivant : lors de la déserialisation j'ai le message d'erreur "Format de serialisation invalide", en testant sur mon téléphone Android. Mais je n'ai pas l'erreur en mode GO.

Voici le code de mon WebService :
bufWS est un Buffer
sdReq est une Source dede Données
sReq est une chaîne
stIngredient est un strListeIngredient
tabStrIngredient est un tableau de strIngredient

sReq = "SELECT * FROM cr_ingredients ORDER BY cr_ingredients.TypeIngredient, cr_ingredients.NomIngredient"

SI PAS HExécuteRequêteSQL(sdReq,sReq) ALORS
SI EnModeTest() ALORS
Erreur(ErreurInfo(errComplet))
FIN
RENVOYER Faux
FIN
HLitPremier(sdReq)
TANTQUE PAS HEnDehors(sdReq)
stIngredient.nIdIngredient = sdReq.IDcr_ingredients
stIngredient.sIngredient = sdReq.NomIngredient
stIngredient.sTypeIngredient = sdReq.TypeIngredient
TableauAjoute(tabStrIngredient,stIngredient)
HLitSuivant(sdReq)
FIN

Sérialise(tabStrIngredient,bufWS,psdXML)

RENVOYER bufWS


Je précise que le webservice et l'application sont dans le même projet et partage donc les mêmes structures.

Si quelqu'un a une idée.

Merci