PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → Exécution du gradle
Exécution du gradle
Débuté par Christian SY, 19 aoû. 2017 16:55 - 5 réponses
Membre enregistré
98 messages
Posté le 19 août 2017 - 16:55
Bonjour,
je viens de basculer en architecture 64 bits. Grosse galère pour installer les outils Androïd sdk, gradle et compilateur Oracle mais bon j'arrive au bout.
Lors de la génération de mon application j'ai ce message à l'exécution du gradle :

Echec de la création de l'application Android <E:\Mes Projets Mobile22\WOSCAR\Exe\Oscar.apk>.
Ligne de commande : "C:\Program Files\Java\jdk1.8.0_144\bin\java.exe" "-Dorg.gradle.appname=E:\Mes Projets
Mobile22\WOSCAR\Android\Generation" -classpath "E:\GRADLE\gradle-4.1\lib\gradle-launcher-4.1.jar"
org.gradle.launcher.GradleMain assembleRelease -b "E:\Mes Projets Mobile22\WOSCAR\Android\Generation\build.gradle"
Erreur retournée :
WARNING: The `android.dexOptions.incremental` property is deprecated and it has no effect on the build process.
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'Generation'.
Failed to notify project evaluation listener.
com.android.build.gradle.tasks.factory.AndroidJavaCompile.setDependencyCacheDir(Ljava/io/File;)V


Quelqu'un ou quelqu'une aurait-il ou t-elle une idée ?

Merci d'avance

--
Christian SY
Membre enregistré
150 messages
Posté le 19 août 2017 - 21:08
Hi. You are using Gradle 4.1 version. The last Gradle correct version for WM is 3.5.1 version. The 4.x versions don't works now.

Rubén
Membre enregistré
98 messages
Posté le 20 août 2017 - 16:02
Hi Rubén thanks you for your answer.
I have find the solution.

Bye

--
Christian SY
Membre enregistré
2 messages
Posté le 09 juillet 2018 - 22:05
Rubén Sánchez Peña a écrit :
Hi. You are using Gradle 4.1 version. The last Gradle correct version for WM is 3.5.1 version. The 4.x versions don't works now.

Rubén

it works thanks
Posté le 11 septembre 2018 - 14:26
Thks a lot, worked for me too !
Membre enregistré
150 messages
Posté le 12 septembre 2018 - 14:42
Gradle 3.5.1 est beaucoup plus rapide que la version 2.14.1 utilisée par WM par défaut. Malheureusement, avec la version 3.5.1, les options de cryptage des chaînes de caractères ou l'utilisation de Proguard pour obscurcir et optimiser la taille de l'application générée ne peuvent être utilisées, ce qui est nécessaire pour la publication d'une application dans Google Play pour des raisons de sécurité. En conséquence, j'utilise la version 3.5.1 pour le développement au jour le jour et seulement la version 2.14.1 lorsque je dois télécharger une application sur Google Play.

Rubén