PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → Erreur système au lancement de la création de l'apk
Erreur système au lancement de la création de l'apk
Débuté par Nicolas WIDMER, 02 mai 2018 18:04 - 3 réponses
Posté le 02 mai 2018 - 18:04
Bonjour à tous,
J'ai depuis plusieurs nouvelles créations d'apk l'erreur système suivante :
"Une erreur système a été détectée pendant l'envoi de la requête HTTP
Message d'erreur système :
Erreur de réception : un problème a été détecté pendant la lecture sur la socket"
Cette erreur ne bloque pas la création de l'apk, mais comment la supprimer ?
Merci de vos idées et solutions !!!
Cordialement,
Nicolas WIDMER
Posté le 02 mai 2018 - 18:44
il semble que WM essaie de téléchargé le gradle et le sdk
si c'est déjà fait tu peut indiqué le répertoire WM personnel
si c'est la première fois vérifie ta connexion internet
Posté le 07 juin 2018 - 15:07
Bonjour,
Après de nombreux essais, vérification connexion internet qui fonctionne, sdk et gradle dans le dossier personnel de WM, je rencontre toujours deux blocages :

Si j'essaye de télécharger les outils gradle et sdk, cela plante sur une erreur de socket... Je précise que je suis en connexion directe sans proxy.

Si je configure par les fichiers présents dans le dossier "personnel" de WM j'ai divers types d'erreur suivant les versions utilisées, dont certaines erreurs sans détail, juste "Failed", comme ci dessous :
Echec de la création de l'application Android <C:\Mes Projets Mobile\GEST_VEHICULES\Exe\Application Android\Gest_Vehicules.apk>.
Ligne de commande : "C:\Program Files\Java\jdk1.8.0_66\bin\java.exe" "-Dorg.gradle.appname=C:\Mes Projets Mobile\GEST_VEHICULES\Android\Generation" -classpath "C:\WINDEV Mobile 22\Personnel\Android\Gradle\lib\gradle-launcher-2.14.1.jar" org.gradle.launcher.GradleMain assembleDebug -b "C:\Mes Projets Mobile\GEST_VEHICULES\Android\Generation\build.gradle"
Erreur retournée :
FAILED

J'ai lu sur le forum qu'il faut le gradle 3.5.1 maximum, là je suis semble t'il avec le 2.14 et le sdk android 25.2.5

Quelles versions faut-il utiliser avec WM 22 ?

Merci de votre aide, car là je suis totalement bloqué...
Nicolas Widmer
Membre enregistré
145 messages
Posté le 08 juin 2018 - 08:34
bonjour
il me semble que le plus simple serait de faire une réinstallation complète de WM, avec toutes les mises à jour.
Et ensuite choisir l'installation automatique de gradle et SDK.
Attention à ton pare-feu, le mieux est de le désactiver pendant 10 minutes.
bonne chance
Christophe