PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 24 → Windev mobile 19 - comment gérer les exigences récentes de Google play - Android 8.0 (niveau d'API 26)
Windev mobile 19 - comment gérer les exigences récentes de Google play - Android 8.0 (niveau d'API 26)
Débuté par G. Henrotin, 04 aoû. 2018 10:32 - 1 réponse
Posté le 04 août 2018 - 10:32
Bonjour,

Depuis 4 ans j'utilise Windev mobile 19 avec complète satisfaction. Je n'ai aucunement besoin des versions supérieures car j'utilise ce programme dans un mode TRES mineur (création de simples publications à base de fichiers htm - sans base de données).

Lors de récentes mise à jour de mes APP, j'ai reçu ce message de Google Play, que certains d'entre vous connaissent peut-être déjà :

"Avertissements
Votre application cible actuellement le niveau d'API 4. Cependant, elle doit cibler le niveau d'API 26 au minimum afin de bénéficier des derniers API, qui sont optimisés au niveau de la sécurité et des performances.
À partir d'août 2018, les nouvelles applications devront cibler Android 8.0 (niveau d'API 26) au minimum.
À compter de novembre 2018, les mises à jour d'applications devront cibler Android 8.0 (niveau d'API 26)."

Le problème est que lors de la séquence de compilation avec Windev mobile 19, le paramètre "SDK à utiliser" reste fixé à 4.4.2 (même s'il est inclus dans un menu déroulant).

Ma question est donc de savoir comment, tout en gardant Windev mobile 19 qui me convient parfaitement, je peux faire en sorte que le SDK Android 8.0 soit repris afin de bénéficier de l'API 26 et rester ainsi en conformiter avec les dernières exigences de Google Play.

Je ne suis pas un technicien de haut niveau en informatique. J'ai besoin d'une solution dont la compréhension reste abordable.

Merci pour votre aide.
Membre enregistré
1 239 messages
Popularité : +9 (11 votes)
Posté le 06 août 2018 - 10:52