PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → Ouvrir PDF sous iOS
Ouvrir PDF sous iOS
Débuté par Beetschen, 04 sep. 2018 14:51 - 3 réponses
Posté le 04 septembre 2018 - 14:51
Bonjour,

J'intègre des fichiers PDF lors de la génération de mon application et je souhaite pouvoir les afficher lorsque je clic sur un bouton. Pour ce faire j'ai choisi d'utiliser la manière "LanceAppliAssociée".

Mon problème est le suivant :
Pour accéder à mon fichier PDF et l'ouvrir, j'utilise la fonction "fExtraitRessource" dans le code suivant :

sCheminDonnees est une chaîne = SysRepCarteStockage() + fSep() + "TestPDF" + fSep()
SI PAS fRépertoireExiste(sCheminDonnees) ALORS fRepCrée(sCheminDonnees)

fExtraitRessource(var_MaRessource, sCheminDonnees + var_MaRessource)

LanceAppliAssociée(sCheminDonnees + var_MaRessource)


Mon problème est assez évident : La fonction "SysRepCarteStockage()" n'existe pas pour iOS.
Et la fonction "fRepEnCours" retourne un dossier inaccessible pour Adobe puisqu'attribué à l'application

Est-ce que quelqu'un aurait une méthode fonctionnant aussi bien sous iOS qu'Android permettant d'afficher un fichier PDF ? Ou peut-être existe-t-il une fonction similaire pour iOS que je n'aurais pas encore découverte ?

Je vous remercie d'avance pour vos réponse.

Bonne suite à vous.
Posté le 05 septembre 2018 - 15:44
Bonjour,

pour ma part j'utilise avec succès le code suivant sur iOS :

sNomPDF est une chaîne = ComplèteRep(fRepDonnées) + "Commande.pdf"
iDestination(iPDFGénérique, sNomPDF)
iImprimeEtat(...)
SI fFichierExiste(sNomPDF) ALORS
LanceAppliAssociée(sNomPDF)
FIN
Posté le 08 septembre 2018 - 17:48
J.FERNANDEZ a écrit :
Bonjour,

pour ma part j'utilise avec succès le code suivant sur iOS :

sNomPDF est une chaîne = ComplèteRep(fRepDonnées) + "Commande.pdf"
iDestination(iPDFGénérique, sNomPDF)
iImprimeEtat(...)
SI fFichierExiste(sNomPDF) ALORS
LanceAppliAssociée(sNomPDF)
FIN



Bonjour,

Merci pour votre réponse.

Cependant je ne comprends pas à quoi sert iImprimeEtat(), je n'ai pas d'etat dans mon application.

Je vous remercie d'avance pour votre réponse.

Excellent week-end à vous.
Posté le 09 septembre 2018 - 21:24
fRepencours est la bonne solution cependant sur l'aide il est écrit
Chemin du répertoire "Documents" de l'application (disponible en lecture/écriture).
Les fichiers sont publics et accessibles par iTunes si cette fonctionnalité est activée.
Il faut donc activé le fait de rendre public ce répertoire.
Par contre je ne l'ai jamais fait.
Source : https://doc.pcsoft.fr/?1000020167