PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → Équivalent fonction Utilise() sous iOS
Équivalent fonction Utilise() sous iOS
Débuté par Beetschen, 08 sep. 2018 18:09 - 2 réponses
Posté le 08 septembre 2018 - 18:09
Bonjour,

Je développe une application sous iOS et Android et j'aimerais ajouter un bouton permettant de revenir au menu principal.

J'emploie donc la fonction Utilise() qui permet de fermer toutes les fenêtres sauf une.

Malheureusement cette fonction ne compile pas sous iOS.

Quelqu'un a-t-il une solution ? Un code pouvant être utilisé des deux côtés ou simplement sur iOS et je séparerais avec <COMPILE SI>.

Je vous remercie d'avance.

Excellent week-end.
Membre enregistré
233 messages
Posté le 10 septembre 2018 - 12:26
je te conseil de privilégier les plans plutôt que de crée des fenêtre.

https://doc.pcsoft.fr/?1013078

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
6 messages
Posté le 19 septembre 2018 - 08:10
Bonjour,

pour iOS, j'ai codé la procédure suivante qui permet de fermer toutes les fenêtres sauf celle qui possède cette procédure.
Il suffit donc de coller ce code dans une procédure locale à la fenêtre de ton menu principal, puis de l'appeler depuis le bouton qui t'intéresse.
En effet, les plans c'est sympa mais s'ils se mettent à contenir l'ensemble de l'application, ça peut devenir un gros bordel.

Procedure pl_Navig_initialise()

// Fermeture de toutes les fenêtres ouvertes autres que celle contenant cette procédure
sFenNom est une chaîne

sFenNom = EnumèreElément(enumFenêtre)

TANTQUE sFenNom <> ""

SI FenEtat(sFenNom) = Inexistant ALORS

// La fenêtre parcourue n'est pas ouverte: on passe à la suivante
SINON

SI sFenNom = MaFenêtre..Nom ALORS

SINON

// Fermeture de la fenêtre autre ouverte
Ferme(sFenNom)
FIN
FIN

// Passage à la fenêtre suivante
sFenNom = EnumèreElément()
FIN


--
Cordialement,
François EVSTRATEV
Message modifié, 19 septembre 2018 - 08:11