PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → BlueTooth LE, qui peut m'éclairer ?
BlueTooth LE, qui peut m'éclairer ?
Débuté par Jean-Philippe DEGLET, 10 nov. 2018 08:14 - 2 réponses
Membre enregistré
124 messages
Posté le 10 novembre 2018 - 08:14
Bonjour,

Je tourne en bourrique avec le BTLE.
Détection, connexion, liste de services, caractéristiques, descripteurs - Okay (déjà là je ne comprend pas à quoi tout cela sert...)
L'exemple de la LST 105 donne les bases techniques mais pas fonctionnelles.

Bref, je ne comprend pas comment "je peux piloter" (carte Blutetooth LE HM-10, en l'occurence).
J'ai installé l'appli BTLE Scanner pour essayer de comprendre et d'interagir,
mais je ne sais pas si la séquence que je tente est la bonne :





Qui peut me mettre sur la voie ?

Côté Android, je trouve des exemples surtout avec de l'Arduino
ou celui d'Enrique Ramirez qui pilote un potentiomètre avec son smartphone
https://medium.com/@enriqueramrezmanzaneda/controlling-a-digital-potentiometer-with-an-android-device-over-ble-using-arduino-1347547e375a

Merci !

--
Cdlt
JPhD
Message modifié, 10 novembre 2018 - 08:17
Membre enregistré
347 messages
Popularité : +2 (2 votes)
Posté le 10 novembre 2018 - 14:40
J'avais commencé à faire des tests avec Arduino et Android sans succès véritable. L'objectif de mon projet était de lire (avec un Arduino) une puce RFID puis d'envoyer la valeur par BlueTooth à unAndroid.

J'arrivais à envoyer une chaine de caractère vers arduino mais l'inverse m'envoyais une chaine de caractère incorrecte.
Il faut également faire attention à la valeur de la fréquence (BAUDS) pour être compatible pour les deux.

Mon projet a été mis en stand by et du coup je n'ai pas approfondi la question.
Voici le code que j'ai utilisé pour écrire vers arduino depuis android :

SI SocketConnecteBluetooth("S_HC-05","SerialPortServiceClass_UUID",gsLeMAC) ALORS
ToastAffiche("Socket créé")
SINON
ToastAffiche("Echec création Socket"+ErreurInfo())
FIN

SI SocketEcrit("S_HC-05", SAI_Envoi) = Vrai ALORS
ToastAffiche("message envoyé")
FIN


Le code pour lire un message envoyé depuis Arduino
SocketAccepte("S_HC-05")
SocketAttendConnexion("S_HC-05",30)

SAI_Recept+=RC+SocketLit("S_HC-05")

//



qui est similaire à celui de la LST
Membre enregistré
124 messages
Posté le 12 novembre 2018 - 10:15
Merci Thierry,

de mon côté j'ai trouvé l'origine de mon pb.
Bref, je transmet mes ordres à la carte en écrivant, en binaire, dans la Custom Characteritic.
mes ordres sont bien reçus et surtout bien exécutés !

@+

--
Cdlt
JPhD
Message modifié, 12 novembre 2018 - 10:16