PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 24 → gestion des contact sous android
gestion des contact sous android
Débuté par alezan, 07 déc. 2018 06:28 - 9 réponses
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 06:28
Je suis entrain de crée une application pour gérer les contact partager de mon entreprise sur des téléphone Android.
mon but et de pouvoir mettre à jour tous les contacts d"une flotte de téléphone qui aurons l'application .

j'ai déjà créer la 1ere partie de l'application l'utilisateur appui sur un boutons :
cela lance la connexion sur un ftp et télécharge un fichier csv contenant les contact à jours.
cela vient remplir un fichier fic avec les contact. jusque la pas de soucis.

ma question que me conseillez vous pour piloter les contact Android depuis mon fichier fic ?
en gros j'ai besoin de mettre à jour les nom en face des numéro de téléphone et de créer les nouveaux contacts si le numéro n'existe pas

merci de votre aide.
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 10:46
alors j'ai avancé, avec le code si dessous cela fonction bien et m'ajoute tous les contact , mais avec mon code je ne trouve pas d'astuce pour mettre a jour le nom du contact si le numéro de telephone est déja dans le répertoire et ainsi ne pas l'ajouter en double quand le numéro existe déjà
sContenuFichier = fChargeTexte("export.csv")

POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne
//NumCol=3
//CONACT.nom=extraitchaine(sLigne,1,";")
//CONACT.Prenom=extraitchaine(sLigne,2,";")
//CONACT.Téléphone_France=extraitchaine(sLigne,3,";")
//hajoute(conact)

// Variables locales
tContact est un Contact
tTéléphone est un Téléphone

// Identité
tContact.Nom = ExtraitChaîne(sLigne,1,";")
tContact.Prénom = ExtraitChaîne(sLigne,2,";")

// Numéros de téléphone Fixe
SI ExtraitChaîne(sLigne,3,";") <> "" ALORS
tTéléphone..Numéro = ExtraitChaîne(sLigne,3,";")
tTéléphone..Type = telDomicile
Ajoute(tContact.Téléphone, tTéléphone)
FIN

// Ajout
SI PAS ContactAjoute(tContact ) ALORS
Erreur("Impossible de créer le contact.")
FIN
FIN
Membre enregistré
165 messages
Posté le 07 décembre 2018 - 12:07
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 13:56
merci j'ai déja vue cette page,
mais je n'arrive pas écrire code qui recherche le numéro dans tous les contact de téléphone Android pour le comparer avec celui de l’extraction de ma chaine
il faudrai surement ecrire quelque chose comme
SI ExtraitChaîne(sLigne,3,";"= "numero existant dans les contact android "ALORS


mais je ne trouve pas la bonne façon de faire cette comparaison.
merci de votre aide
Membre enregistré
165 messages
Posté le 07 décembre 2018 - 14:02
Je vois que vous pouvez aussi faire appel à ContactListe et appliquer un filtre sur le numéro de téléphone
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 15:21
alors j'ai fait ce code la.
mais il ne fonction pas, je me retrouve avec un seul contatc à la fin

sContenuFichier = fChargeTexte("export.csv")
Sablier(Vrai)

POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne
// On recherhce si le numéro de téléphone existe dans les contact
SI ContactCherche(contactTéléphone,ExtraitChaîne(sLigne,3,";"),mContact.TéléphoneMobile,Vrai) ALORS
//on mets a jours les information du nom et prénom
mContact.Nom = ExtraitChaîne(sLigne,1,";")
mContact.Prénom = ExtraitChaîne(sLigne,2,";")
ContactModifie(contactTéléphone)
SINON
// on créer le contact
mContact.Nom = ExtraitChaîne(sLigne,1,";")
mContact.Prénom = ExtraitChaîne(sLigne,2,";")
mContact.TéléphoneMobile = ExtraitChaîne(sLigne,3,";")
ContactAjoute(contactTéléphone)
FIN
FIN
Sablier(Faux)
Info("Terminé")


pouvez vous me dire ou je me loupe ? merci.
Membre enregistré
165 messages
Posté le 07 décembre 2018 - 16:59
Si vous faites :
TabListeContacts est un tableau de Contact = ContactListe(Null, contactTéléphone, ExtraitChaîne(sLigne,3,";"))

dans la boucle, vous obtenez quoi? Sinon, je pense qu'il faudrait se pencher sur le format des numéros de téléphone
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 17:07
je viens de tenter sa, cela ne marche pas non plus ;(
sContenuFichier = fChargeTexte("export.csv")
Sablier(Vrai)
POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne

mContact.Nom = ExtraitChaîne(sLigne,1,";")
mContact.Prénom = ExtraitChaîne(sLigne,2,";")
mContact.TéléphoneMobile = ExtraitChaîne(sLigne,3,";")
SI ContactCherche(contactTéléphone,ExtraitChaîne(sLigne,3,";"),mContact.TéléphoneMobile,Vrai) ALORS
ContactModifie(contactTéléphone)
SINON
ContactAjoute(contactTéléphone)
FIN
FIN
Sablier(Faux)
Info("Terminé")
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 17:19
Merci je n'avais pas vue votre message.
je regarde ce que j’obtiens tout de suite:D
Membre enregistré
13 messages
Posté le 07 décembre 2018 - 17:30
ROMULUS001 a écrit :
Si vous faites :
TabListeContacts est un tableau de Contact = ContactListe(Null, contactTéléphone, ExtraitChaîne(sLigne,3,";"))

dans la boucle, vous obtenez quoi? Sinon, je pense qu'il faudrait se pencher sur le format des numéros de téléphone



je n'ai pas bien compris votre morceau de code.


en le testant je n'ai aucun résultat ? . mais en même je ne l'ai pas compris :(

est ce bien cela que vous m'avez demmander de tester ?
sContenuFichier = fChargeTexte("export.csv")
Sablier(Vrai)

POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne
TabListeContacts est un tableau de Contact = ContactListe(Null, contactTéléphone, ExtraitChaîne(sLigne,3,";"))
FIN
Sablier(Faux)
Info("Terminé")