PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 25 → UPDATE DANS UNE BASE ACCESS
UPDATE DANS UNE BASE ACCESS
Débuté par Camille, 19 nov. 2019 19:08 - 3 réponses
Posté le 19 novembre 2019 - 19:08
Pourquoi la requete UPDATE suivante pour écrire dans une base ACCESS ne marche pas, depuis un mobile ANDROID ?

NumConnexion = SQLConnecteWS(REPERTOIRE_BASE_DE_DONNEES, ...
"BATIFLOW", "", "", NomSource,"ODBC",hODBC)

SI NumConnexion <1 ALORS
// La connexion a échoué : affichage d'un message explicatif
SQLInfoGene()
Erreur("La connexion à la source de données " + NomSource + ...
" a échoué." + RC + "Code erreur : " + ...
SQL.Erreur + RC + SQL.MesErreur)
FinProgramme()
FIN
//
sSql est une chaine=("UPDATE RAPPORT SET RAPPORT.NOTE = 'TEST' WHERE RAPPORT.CODE='40001' '"

SI PAS SQLExec(sSql, "REQRAPPORT") ALORS
SQLInfoGene()
Info(SQL.Erreur + RC + SQL.MesErreur)
FIN
SQLFerme("REQRAPPORT")
Membre enregistré
500 messages
Posté le 19 novembre 2019 - 23:09
Salut @camille,
pour accéder a une base accès
tu créer un web service avec windev ou webdev qui y accèderont par odbc
ce web service servira d'intermédiaire entre Android et ta base
Posté le 21 novembre 2019 - 20:36
Merci mais le Web Service WDSOAPDB est bien actif, sur le serveur, il permet la connexion par sqlconnect. Il faut créer un autre ?
Membre enregistré
2 messages
Posté le 21 novembre 2019 - 20:47
Bonjour. Je vois que vous utilisez SQLConnecteWS . . Je l'ai mis en œuvre sans trop de soucis . débogage sur mon poste sans pb . synchro de base hfsql coté client et SQL server côté server. Jusqu'au moment ou j'ai porté l'application sur 2 tablettes androids . 1 en 7.0 et 1 en 9.0.

Et là , le drame.... la fonction me retourne 0 a la connexion alors qu'avec le simulateur de tablette , je n'ai aucun soucis de communication.....

Avez vous fait un manipulation particulière ? estce votre sql exec qui ne passe pas ou la connection via SQLConnecteWS ?

après appel au sav pc soft il y a une histoire de protocole HTTPS obligatoire pour la connection ou HTTP lorsqu'on modifie le manifest xml à la génération de l'appli.