PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 25 → Erreur APK
Erreur APK
Débuté par Didier Malemba, 23 nov. 2019 11:18 - 1 réponse
Posté le 23 novembre 2019 - 11:18
Echec de la création de l'application Android <C:\Mes Projets Mobile\Gestion données Scolaire\Exe\KeSoft Application.apk>.


Ligne de commande : "D:\Program Files\Java\jdk1.8.0_231\bin\java.exe" "-Dorg.gradle.appname=C:\Mes Projets Mobile\Gestion données Scolaire\Android\Gen" -classpath "D:\gradle-3.1\lib\gradle-launcher-3.1.jar" org.gradle.launcher.GradleMain assembleDebug -b "C:\Mes Projets Mobile\Gestion données Scolaire\Android\Gen\build.gradle"


Erreur retournée :
Starting a Gradle Daemon, 2 busy Daemons could not be reused, use --status for details
WARNING: The `android.dexOptions.incremental` property is deprecated and it has no effect on the build process.
Observed package id 'build-tools;29.0.2' in inconsistent location 'D:\Logiciels\SDK\build-tools\android-10' (Expected 'D:\Logiciels\SDK\build-tools\29.0.2')
Observed package id 'build-tools;27.0.1' in inconsistent location 'D:\Logiciels\SDK\build-tools\android-8.1.0' (Expected 'D:\Logiciels\SDK\build-tools\27.0.1')
Observed package id 'platforms;android-29' in inconsistent location 'D:\Logiciels\SDK\platforms\android-10' (Expected 'D:\Logiciels\SDK\platforms\android-29')
Observed package id 'platforms;android-27' in inconsistent location 'D:\Logiciels\SDK\platforms\android-8.1.0' (Expected 'D:\Logiciels\SDK\platforms\android-27')
Observed package id 'build-tools;29.0.2' in inconsistent location 'D:\Logiciels\SDK\build-tools\android-10' (Expected 'D:\Logiciels\SDK\build-tools\29.0.2')
Observed package id 'build-tools;27.0.1' in inconsistent location 'D:\Logiciels\SDK\build-tools\android-8.1.0' (Expected 'D:\Logiciels\SDK\build-tools\27.0.1')
Observed package id 'platforms;android-29' in inconsistent location 'D:\Logiciels\SDK\platforms\android-10' (Expected 'D:\Logiciels\SDK\platforms\android-29')
Observed package id 'platforms;android-27' in inconsistent location 'D:\Logiciels\SDK\platforms\android-8.1.0' (Expected 'D:\Logiciels\SDK\platforms\android-27')
Observed package id 'build-tools;29.0.2' in inconsistent location 'D:\Logiciels\SDK\build-tools\android-10' (Expected 'D:\Logiciels\SDK\build-tools\29.0.2')
Observed package id 'build-tools;27.0.1' in inconsistent location 'D:\Logiciels\SDK\build-tools\android-8.1.0' (Expected 'D:\Logiciels\SDK\build-tools\27.0.1')
Observed package id 'platforms;android-29' in inconsistent location 'D:\Logiciels\SDK\platforms\android-10' (Expected 'D:\Logiciels\SDK\platforms\android-29')
Observed package id 'platforms;android-27' in inconsistent location 'D:\Logiciels\SDK\platforms\android-8.1.0' (Expected 'D:\Logiciels\SDK\platforms\android-27')
java.net.UnknownHostException: dl.google.com
Failed to connect to host: https://dl.google.com/android/repository/addons_list-3.xml
Failed to connect to host: https://dl.google.com/android/repository/addons_list-2.xml
Failed to connect to host: https://dl.google.com/android/repository/addons_list-1.xml
Failed to download any source lists!

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'Gen'.
> Could not resolve all dependencies for configuration ':_debugApkCopy'.
> Could not resolve com.android.support:support-v4:26.1.+.
Required by:
project :
> Could not resolve com.android.support:support-v4:26.1.+.
> Failed to list versions for com.android.support:support-v4.
> Unable to load Maven meta-data from https://maven.google.com/com/android/support/support-v4/maven-metadata.xml.
> Could not GET 'https://maven.google.com/com/android/support/support-v4/maven-metadata.xml'.
> maven.google.com
> Could not resolve com.android.support:support-v4:26.1.+.
> Failed to list versions for com.android.support:support-v4.
> Unable to load Maven meta-data from https://jcenter.bintray.com/com/android/support/support-v4/maven-metadata.xml.
> Could not GET 'https://jcenter.bintray.com/com/android/support/support-v4/maven-metadata.xml'.
> jcenter.bintray.com
> Could not resolve com.android.support:appcompat-v7:26.1.+.
Required by:
project :
> Could not resolve com.android.support:appcompat-v7:26.1.+.
> Failed to list versions for com.android.support:appcompat-v7.
> Unable to load Maven meta-data from https://maven.google.com/com/android/support/appcompat-v7/maven-metadata.xml.
> Could not GET 'https://maven.google.com/com/android/support/appcompat-v7/maven-metadata.xml'.
> maven.google.com
> Could not resolve com.android.support:appcompat-v7:26.1.+.
> Failed to list versions for com.android.support:appcompat-v7.
> Unable to load Maven meta-data from https://jcenter.bintray.com/com/android/support/appcompat-v7/maven-metadata.xml.
> Could not GET 'https://jcenter.bintray.com/com/android/support/appcompat-v7/maven-metadata.xml'.
> jcenter.bintray.com

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 29.363 secs
Membre enregistré
10 messages
Posté le 24 novembre 2019 - 01:54
Bonjour
a tu déjà généré une foie ton apk

--
@armel@