PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 23 → How to enumerate elements found in a Table Container column?
How to enumerate elements found in a Table Container column?
Débuté par Vadim, 07 sep. 2018 09:35 - 1 réponse
Posté le 07 septembre 2018 - 09:35
Hello, everyone!

I have an AJAX table with a container column with several buttons inside.
How can I enumerate them correctly in WLanguage?
I tried different functions like EnumControl, EnumSebEelement, TableEnumColumn etc.
But they all return empty string...

Many thanks for any help in advance!
Posté le 09 octobre 2018 - 19:01
Hi,

Here is a exemple of code ( sorry it's in french ) , see below.

You must work with a "champ" ( "Field" in englis) type variable. Then, you can scan the type of the Field.

See the web page https://doc.pcsoft.fr/fr-FR/?2510131 and traduce in English.

Fo a colonne, you must control with "52"

// > Parcours des champs de la fenêtre <
// > Variable de type champ (chaine) <
ChmRcvChamp est une Champ

// > Analyse des champs de la fenêtre <
// > Extraire le type d'un champ : https://doc.pcsoft.fr/fr-FR/?2510131 <
EntIdce = 1

// > Receptionne le champ de la fenêtre dans une variable Champ <
// > Attention : doit faire une prise de référence <
QUAND EXCEPTIONEXCEPTION DANS
ChmRcvChamp <- EnumèreChamp(_NomFenetreAppelante,EntIdce)
FAIRE
// > Pas de prise de référence : on force le pointeur à "Null"
ChmRcvChamp <- Null
FIN

// Plus ( ou pas de champ ) dans la fenêtre.
TANTQUE ChmRcvChamp <> Null

// > Type de chmp COMBO <
SI ChmRcvChamp..Type DANS (52)

FIN


Good dev.