PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 25 → Webdev + MariaDB + Docker problem
Webdev + MariaDB + Docker problem
Débuté par Joe, 23 mar. 2020 13:14 - 3 réponses
Posté le 23 mars 2020 - 13:14
When I create an image of my solution, everything is done correctly except the inclusion of MariaDB dependencies.
How to add to the Docker image and install the respective driver (wd240maria64.so).
Thanks
Posté le 25 mars 2020 - 08:26
Hi

I vahe installed this
https://repository.windev.com/resource.awp…

in C:\Program Files\PC SOFT\WEBDEV 24\Programs\Framework
Here there two folder for 32 or 64 bit verson of OS

besides that you have to install this too

https://mariadb.com/kb/en/about-mariadb-connector-c/

so I managed to make it work
If you deploy, you must also install Maria DB on the server

Mimmo
Posté le 25 mars 2020 - 08:26
Hi

I vahe installed this
https://repository.windev.com/resource.awp…

in C:\Program Files\PC SOFT\WEBDEV 24\Programs\Framework
Here there two folder for 32 or 64 bit verson of OS

besides that you have to install this too

https://mariadb.com/kb/en/about-mariadb-connector-c/

so I managed to make it work
If you deploy, you must also install Maria DB on the server

Mimmo
Posté le 25 mars 2020 - 12:02
Thanks for the answer.

I can connect to the BD without problems (in development mode and direct deploy), I just can't include the respective drivers in the image of the docker, I always have to change the image manually. Not persistent.

Regards,
Joe