PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 22 → Trying to implement AcceptEmail webservices
Trying to implement AcceptEmail webservices
Débuté par Marc Borghers, 08 mar. 2017 12:16 - 1 réponse
//hostimage.webdev.info/avatars/default.gif
Posté le 08 mars 2017 - 12:16
HI,

For a client of mine I have to implement the AcceptEmail Webservices. I do have experience with consuming webservices however here I get some errors when I want to load the WSDL (https://webservices.acceptemail.com/ws3/wsdl/wsdl.xml)

**********************************************

Failure retrieving the schema.
The schema has not been loaded.
----------------------------------------------
The schema has not been loaded.
System Error Details:

Element '{http://www.w3.org/2001/XMLSchema}pattern': The value '^[a-zA-Z0-9!#$%%&'*+/=?^_`{|}~-]+(?:\.[a-zA-Z0-9!#$%%&'*+/=?^_`{|}~-]+)*@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?\.)+(?:[a-zA-Z]{2,20})$' of the facet 'pattern' is not a valid regular expression.

Element '{http://www.w3.org/2001/XMLSchema}pattern': The value '^\+?[1-9]{1}([\ \-0-9]){9,14}$' of the facet 'pattern' is not a valid regular expression.

Element '{http://www.w3.org/2001/XMLSchema}pattern': The value '(^[a-zA-Z0-9!#$%%&'*+/=?^_`{|}~-]+(?:\.[a-zA-Z0-9!#$%%&'*+/=?^_`{|}~-]+)*@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]*[a-zA-Z0-9])?\.)+(?:[a-zA-Z]{2,20})$)|(^\+?[1-9]{1}([\ \-0-9]){9,14}$)' of the facet 'pattern' is not a valid regular expression.


----------------------------------------------

----------------------------------------------
Failure initializing the 'IAEService_UpdateMandateStatus_OutputMessage' message. Some parameters have not been initialized.
----------------------------------------------

----------------------------------------------
Failure initializing the 'IAEService_UpdateMandateStatus_InputMessage' message. Some parameters have not been initialized.
----------------------------------------------

Anyone any suggestions ?

Thank you
Marc
//hostimage.webdev.info/avatars/default.gif
Posté le 27 avril 2017 - 13:02
Hi Marc,

I have the same problem. Have you found the solution?

Thank you!

Alfons