PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 23 → Windows 10 April 2018 update Problem
Windows 10 April 2018 update Problem
Débuté par Rasta, 14 mai 2018 19:36 - 13 réponses
Posté le 14 mai 2018 - 19:36
Hello,

Since Windows 10 April 2018 Update came out, all the clients that have been updated cannot connect to the local server where the application and database are located, while those that have older version of Windows 10 or Windows 8 and 7 can.

I have tried installing HFSQL Control Center on the client machine and tried to connect to the database on the server to see if it would work, and it connected without any problems.

Problem happens when I run my application on the client machine, I get an error saying that connection could not be established.
Error code: 74000
Level: non-fatal error
WD55 error code: 4000

One workaround was that I copied application .exe file and all .dll files to the local machine, and when I run it like that, it also connects to the server without any problems.
This is bad solution as I want to control all clients from the server, but it is a temporary solution until I find out what they did in Windows 10 April 2018 update that is causing these problems.

Did anyone else have any problems with Windows 10 Update??

Kind Regards,
Rasta
Posté le 14 mai 2018 - 19:47
Today, I experienced the same problem with one client PC.
This problem is not WX DLLs or somthing similar. Is just one of the Windows 10 beauties !!!:mad:
The solution ?
After completion of the update, reboot and everything was Ok.!!

Regards
Vassilis Boutsikas
Posté le 14 mai 2018 - 22:35
Hi

Everything works fine with win10pro-64bit redstone 1803 and I also update to
v23 hfSQL server side and couldn't find any issue by far.

I do have win10pro-64/win7/64-32 clients connections to win10pro-64bit redstone 1803
with wx works a charm.

Can you tell what wx version/hardware that you're using?
I guess it's the windows defender blocks the connection indeed.

Regs

King
Posté le 15 mai 2018 - 18:30
Regards to all

I have similar problem with connection but all problems was on server side. If you try to install HF Center on client side and connect from server on Windows 10 updated to latest version you will see all works fine.

What I am do.
Delete all Windows firewall rules on SERVER HFSQL for port 4900 and add new (same TCP and UDP) 4900 port. Now all PC's updated or not can make connection.

Maybe you have also same situations.
Posté le 17 mai 2018 - 15:37
Hi everybody,

pcsoft published an article on the problem:
http://faq.pcsoft.fr/16657-windows_10_april_update_connexion_hfsql_emailouvresession-read.awp

it's in french, but google translate is your friend

Best regards
Posté le 17 mai 2018 - 15:51
Hi Fabrice, translation to English ...

What to do under "Windows 10 April 2018 Update" (1803) if network communications (HFSQL, Email...) fail?

Workstations on which the update "Windows 10 April 2018 Update" (1803) may no longer be able to connect to a data server, or send emails.

For example, a WINDEV application will no longer be able to:

connect to the client/server HFSQL engine,
connect to a database via ODBC, OLE DB,
send an email.

This connection block occurs when the application executable runs under "Windows 10 April 2018 Update":

is on a shared resource on a Windows server,
AND that this shared resource does not have SMBv2 (Server Message Block) enabled.

In this case no code or compilation changes need to be made to the WINDEV application. It is only a change of Windows that induces this new behavior.

The solution is to enable SMBv2 on the share, or place the application on another share that has SMBv2. This version of "Windows 10 April 2018 Update" requires the use of SMBv2 for security reasons, otherwise communication features are blocked.

The following page contains complete information about SMBv2 (Server Message Block) :

https://support.microsoft.com/fr-fr/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

Translated with www.DeepL.com/Translator
Posté le 18 mai 2018 - 13:21
Hi all,

I'm sorry I ever got trapped into using Windows 10. Every update seems to introduce new problems.
Just like Firefox -that seems to have an update every time I start it- fell from being my favorite browser to most annoying browser.
Fortunately WX products have only one update a year ;)

Kind regards,
Piet
Posté le 23 mai 2018 - 16:27
Greetings,

I followed the guide for enabling SMBv2 service,but still no luck. The problem is still there.

The procedure I followed is this:

1. On server computer I enabled SMBv1 and SMBv2 just in case that it was not enabled.
SMBv1
Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Value 1 -Force
SMBv2
Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB2 -Type DWORD -Value 1 -Force
After that I restarted Server

2. Then on client computer I did following:
SMBv1
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb10 start= auto

SMBv2
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

After that I restarted client computer but problem was still there.
When I used shell command to detect SMBv2, it said that it was running.

If anyone else followed this guide and had success, could you please write it here. Maybe I missed something. I would really appreciate it.

Kind regards,
Rasta
Posté le 23 mai 2018 - 17:07
Rasta

Try to disable any Windows Defender/any firewall for short to see
if this is the case. Are you using Windows 10-64 Pro or Enterprise?

HTH

King
Posté le 23 mai 2018 - 18:41
Hi,

I tried disabling firewall. Doesn't work.

The small company that is using my application has two Win 10 Home edition computers. One is acting as server.
Could Home version be a problem?

Kind regards,
Rasta
Posté le 23 mai 2018 - 19:26
Hi Rasta, yes, "Home" is definitely not working as a server ...
Posté le 24 mai 2018 - 18:02
Greetings,

It worked alright until this last update. I know that Home version is limited, but it did simple file sharing job, and it worked. Also the problem appeared on Windows 10 Pro machine, and this SMBv2 solution is not solving the issue.

I can see server on the network and access its files. The client machine is running application on the server, and only problem seems to be when connecting to the database. Something is blocking it.


Error I keep getting:
Error at line 24 of Global Procedure getSettings process.
HReadFirst function called.
Unable to create <\\server1\ est\SETTINGS.FIC> file.

System Error Details:

Access is denied.
(5)

----- Technical Information -----

Project : Test

WL call:
Process of 'Global Procedure getSettings' (SET_GlobalneProcedure_TEST.getSettings), line 24, thread 0
'HReadFirst' function, syntax 3

What happened?
Unable to create <\\server1\ est\SETTINGS.FIC> file.

Error code: 70152
Level: fatal error
WD55 error code: 152

System error code: 5
System error message:
Access is denied.

Dump of the error of 'wd220hf.dll' module (22.0.85.1).
Debugging information:
##(IXStream)-Handle=##
Function (7,10)
Additional Information:
EIT_SRCFILE : <\\server1\ est\SETTINGS.FIC>
EIT_XINFO : <1>
EIT_LOGICALTABLENAME :
EIT_PILEWL :
Global Procedure getSettings (SET_GlobalneProcedure_TEST.getSettings), line 24
Initializing TEST (), line 215
EIT_DATEHEURE : 24/05/2018 17:52:34
EIT_TYPE_WDFILE : <7>
EIT_IDCODE : <458752>

And second error is in the attachment.

Kind regards,
Rasta
[attachment 2710 error.jpg]
Posté le 24 mai 2018 - 19:08
Hi

It has nothing to do with hfSql but it is sharing folder problem in

\\server1\ est\

clearly said ACCESS right issue on ie CREATE/READ/WRITE/DELETE problem.

Pls check your folder in Windows explorer to see if it's shared with R/W.

HTH

King
Posté le 25 mai 2018 - 10:39
I had the same problem i turned on SMB and was still the same.

I fixed it by changing the servername to the IP address

FROM

Connection..Server = "SERVERNAME:4900"

TO

Connection..Server = "192.168.10.101:4900"

i would prefer to use the Server Name so its only a workaround as i needed to get it back up and running quickly.