PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 23 → [WD,WB21] Urgent Help Dongles are not working at at all!!
[WD,WB21] Urgent Help Dongles are not working at at all!!
Débuté par Biju, 27 juin 2018 10:02 - 6 réponses
Posté le 27 juin 2018 - 10:02
Hello all,
My Dongles windev & Webdev connect to shared USB Hub and its working for a long time. But today onward both not working at all. ( its LED not working ) Any suggestion?

Thanks

Biju
Posté le 27 juin 2018 - 10:53
Hi,

Has anything changed since you last used them? i.e. any WX updates, Windows updates etc...?

Not sure what you mean by a "shared" hub. The whole point of the dongle is that it's specific to a PC - i.e. it's a single license.

Have you tried plugging them directly into the dev PC that you are using as a test to see if it's the HASP drivers?
Posté le 27 juin 2018 - 10:59
Hi Darren Farmer
shared means a USB hub with 4 ports and I tried to use with Direct PC also
the devise is not reading and there is no light seams totally dead I use 2 dongle in the USB HUB both have the same problem
Posté le 27 juin 2018 - 11:20
Hi,

I have all 3 WX dongles in a USB hub and no issues. I've recently applied the recent Win10 update and upgraded to WX23 product with no issues. It's strange that both dongles have stopped working. The last (and only) time this happened to me, the HASP drivers needed to be updated.

You don't say if you've recently updated or upgraded anything on your dev PC, but I would defiinately look into updating your HASP drivers ...OR... something that has just come to mind - you might also investigate to see if your Virus s/w is causing any issues?
Posté le 27 juin 2018 - 12:09
You could first try another pc to see if the dongles itself aren't broken in the first place. That would be very bad luck, afaik these kind of dongles are rather stable. But there is a small risk the USB-hub caused the dongles to be damaged.

I don't want to worry you, I'm also using a USB-hub for years now without any problems.

I assume you are ceratin that the USB port is functioning i.e. by attaching a mouse or some other device?

If that is all ok it is almost certain some software isssue, as Darren mentioned. Anti-virus, remove drivers, etc.
Posté le 02 juillet 2018 - 11:55
Hi,

I'm having a very similar problem. About a week or so ago, whilst working offsite, both my dongles (WD & WB) could not be recognised by Windows 10.

The following morning, back at my office, I powered up the same pc, plugged the dongles in and everything was fine!

I'm now away on holiday, needed to sort out a minor user issue, so turned on the laptop and once again the dongles are not being recognised.

At all times the dongles lights have been on and Windows 10 appears to "see" them because it bleeps when I plug them in.

I have tried running the haspdinst.exe program to remove and reinstall the hasp drivers, to no avail.
Does anyone have any other possible suggestions?

Kind Regards
Reg
Posté le 07 juillet 2018 - 12:07
In case this helps anyone I had to uninstall the dongle devices as shown in the devices part of the control panel. Then simply plugging them back re-installed them as devices and everything has been fine since.


Cheers
Reg