PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 24 → GPSFollwMovement ... struggle
GPSFollwMovement ... struggle
Débuté par zwaailicht, 27 fév. 2015 17:35 - 5 réponses
Membre enregistré
15 messages
Posté le 27 février 2015 - 17:35
I am working on a testtool for GPS/geo an iPhone.
Just struggling to get it working and I also can not find some extra information/examples.

Does anybody has some working examples maybe??
Membre enregistré
2 958 messages
Popularité : +89 (91 votes)
Posté le 27 février 2015 - 18:11
Tem diversos posts meus sobre esse assunto no forum oficial da Pcsoft - categoria Windev Mobile US (americano), só procurar por Adriano Boller no find de busca, deve aparecer todos 700 os posts sobre mobile que ja enviei, tem sobre esse assunto, bem como no help e help online.
Membre enregistré
2 958 messages
Popularité : +89 (91 votes)
Posté le 27 février 2015 - 18:15
Has many my posts on this topic on the official forum of PCSoft - category Windev Mobile US (American), only search for Adriano Boller in search find, you should see all my 700 on mobile including on what you need to know about GPS that already sent has on this subject, as well as help and online help. Remember that what makes the android is the same thing in iPhone ios language is the same.
Membre enregistré
15 messages
Posté le 28 février 2015 - 14:34
Some extra information

When starting the app I call this procedure :

PROCEDURE Init_GPS()
GPSInitParameter(gpsAuto,gpsEnergyHigh+gpsPrecisionHigh)

No errors on this part.

The test-app has only one screen, with a few buttons.
To find out if the iPhone has GPS enabled I use :


SWITCH GPSStatus()
CASE gpsEnabled
STC_GPSSATUS = "Actief"
CASE gpsDisabled
STC_GPSSATUS = "NIET actief"
OTHER CASE

END

Also working fine.

But ont the button for getting my GPS-location I get errors :

iPosition is géoPosition
iPosition = GPSGetPosition(600,"Effe wachte ....")

STC_INIT = iPosition..Longtitude

When testing it in Xcode it get the following error-message :

A fatal error occured on the íPosition-element (of geoPosition) and prevents it from using it.
Membre enregistré
15 messages
Posté le 03 mars 2015 - 19:09
Found the first part of my problem. My WinDEV app works. I have to disable on my iPhone Location Services.
Then my app works just one time. After this time location services on the iPhone are disabled.
When installing (out of Xcode testmode) the app, there was no question to the user if the app may use the location services.

Somehow, and I am am figuring out, CLLocationManger in Xcode is not active.
I am now looking for the solution : if I have to ad more code to WinDEV or if I have to make adjustments to the app in Xcode.

I'll keep jou informed here.
Membre enregistré
15 messages
Posté le 09 mars 2015 - 20:49
Already some bit further .....
But when I test the app (trough Xcode 6.1.1) on my iPhone 6 I can see in the list of apps that use location services my app listed. But not yet allowed to use location.
When I (manually) grand my app to use the location services the app works one time oke. The second time the app hangs and on my app is disabled in the location services.

I have tried te figure out if my problem is programming in WinDEV of something in Xcode ......
Maybe one of you has experiences with this matter.