PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 24 → Installing and Compiling with API level 26 Android
Installing and Compiling with API level 26 Android
Débuté par Rogelio, 10 mai 2018 22:36 - 9 réponses
Posté le 10 mai 2018 - 22:36
Hello there people, as you all know from August 2018 all android apps will have to target AT LEAST API level 26 to be able to upload to the google play store. the problem is that Windev mobile 22, as long as you tell it to download automatically graddle and the android SDK all is good, but the way the IDE downloads the SDL is weird because there is no SDK manager or nothing, and if you download it yourself and install it if you tell windev the directory where the SDK is the build just fails saying you are using deprecated features and that that are not compatible wit Gradle 5.0.

Has anyone succeeded with installing both Graddle and Android SDK where you can easily add API levels and use them for compilation that actually works ? How can i add the API level 26 to Windev 22 and use it ?

Thanks
Membre enregistré
202 messages
Posté le 11 mai 2018 - 14:53
Hi.

The last correct Gradle version for WM is the 3.5.1 version. All later versions do not work, but 3.5.1 is good.

For the SDK try https://developer.android.com/studio/…, you can update this SDK version.

Rubén
Posté le 11 mai 2018 - 17:04
Thanks Ruben
Posté le 24 mai 2018 - 09:25
Rubén Sánchez Peña wrote:
Hi.

The last correct Gradle version for WM is the 3.5.1 version. All later versions do not work, but 3.5.1 is good.

For the SDK try https://developer.android.com/studio/…, you can update this SDK version.

Rubén


Hi Rubén,
i'm using the last US version of WM 23 (50u) with gradle 3.5.1 and Android version 8.0.1, and when i upload an app to the Play Store i get a warning because i'm using api level 24 (theoretically it should be api level 26)
Do you know what is the problem ?
Membre enregistré
5 messages
Posté le 25 mai 2018 - 12:05
Answer from pc-soft technical support:

"The "Update 3" of WINDEV Mobile 23, which is soon online, has been adapted to this Google request:

- the target API level has been raised to 26,

- the framework has been adapted to compensate for the changes imposed by this change.

You therefore have no immediate action to perform, simply recompile your application with the update of WINDEV Mobile 23. "
Posté le 26 septembre 2018 - 17:03
How exactly do you target API level 26 and up?
Does it mean you have to choose Android 8.0 and up?
Will phones running 7.0 and lower not be able to use the app?

Thanks

Jim
Membre enregistré
202 messages
Posté le 27 septembre 2018 - 19:32
Hi, really only devices with Android version >= 26 will be able to take advantage of the new security features of the SDK (the question to the user about the "dangerous" permissions that the application uses). The problem comes when a previous version of the SDK is used in devices that can use these new security advantages, so they don't really apply and the device still uses the features of the old ones to work.

Rubén
Posté le 19 mars 2019 - 00:23
no es necesario actulizar a la version 23 o 24 se puede corregir en la compilacion con 21 y 22 sin problemas
Posté le 19 mars 2019 - 00:23
no es necesario actulizar a la version 23 o 24 se puede corregir en la compilacion con 21 y 22 sin problemas
Membre enregistré
202 messages
Posté le 01 avril 2019 - 17:44
Hi. You can change the compilation SDK to version 26 as you say. The problem is that in versions 21 and 22 that you mention if you make that change will give you runtime errors, since they are not prepared for the new needs of version 26.

The WM framework needs to be compatible with the SDK on which it should work, and if you mix old framework with new SDK, only new problems can appear.

Rubén
Message modifié, 01 avril 2019 - 17:46