PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 23 → [WM23] FTPSEND curious problem
[WM23] FTPSEND curious problem
Débuté par VEGEboss, 28 juin 2018 10:15 - 1 réponse
Posté le 28 juin 2018 - 10:15
hello folks


I just published a new App for Android (the iOS version in the next days) and I have, as in the subject, a strange problem using the FTPSEND function

Due to the data size of the transmitting files (about 10 Mb or more) I used the "Procedure Name" parameter to call a little routine for a simply display of the advancing job

...nothing happens!
When I test it in the WM environment I can see the progress, but when I install to my Android device… nothingh happens!

But ther's another curious fact; I have inserted, in the called function, an Info ( size ) to see if the program, at least, passes there… and it works! With this "pause" I can easily read the job progress

But without the "Info" nothing happens… :( :( :(

...just to resume: THIS WORKS!

Procedure myGauge(nTotal, nCurrent)
STC_FTPprogress..Value = "Transmitted: " + NoSpace ( NumToString ( nCurrent, "10ds" ) ) + " of " + NoSpace ( NumToString ( nTotal, "10ds" ) ) + " (" + Percent( nCurrent, nTotal ) + ")"
Info (ncurrent)
RESULT True


and this DON'T WORKS

PROCEDURE myGauge(nTotal, nCurrent)
STC_FTPprogress..Value = "Transmitted: " + NoSpace ( NumToString ( nCurrent, "10ds" ) ) + " of " + NoSpace ( NumToString ( nTotal, "10ds" ) ) + " (" + Percent( nCurrent, nTotal ) + ")"
RESULT True
Posté le 28 juin 2018 - 14:39
Hi
try adding a multitaks or multitaskredraw in your procedure code, AFTER
the progressbar change.

Best regards

--
Fabrice Harari
International WinDev, WebDev and WinDev mobile Consulting

Free Video Courses, free WXShowroom.com, open source WXReplication, open
source WXEDM.

More information on http://www.fabriceharari.com


On 6/28/2018 1:15 AM, VEGEboss wrote:
hello folks


I just published a new App for Android (the iOS version in the next
days) and I have, as in the subject, a strange problem using the FTPSEND
function

Due to the data size of the transmitting files (about 10 Mb or more) I
used the "Procedure Name" parameter to call a little routine for a
simply display of the advancing job

....nothing happens!
When I test it in the WM environment I can see the progress, but when I
install to my Android device… nothingh happens!

But ther's another curious fact; I have inserted, in the called
function, an Info ( size ) to see if the program, at least, passes
there… and it works! With this "pause" I can easily read the job progress

But without the "Info" nothing happens…     :(  :(  :(

....just to resume: THIS WORKS!

PROCEDURE myGauge(nTotal, nCurrent)
   STC_FTPprogress..Value = "Transmitted: " + NoSpace ( NumToString (
nCurrent, "10ds" ) ) +  " of " +  NoSpace ( NumToString ( nTotal, "10ds"
) ) + " (" + Percent( nCurrent, nTotal )  + ")"
   info (ncurrent)
RESULT True


and this DON'T WORKS

PROCEDURE myGauge(nTotal, nCurrent)
   STC_FTPprogress..Value = "Transmitted: " + NoSpace ( NumToString (
nCurrent, "10ds" ) ) +  " of " +  NoSpace ( NumToString ( nTotal, "10ds"
) ) + " (" + Percent( nCurrent, nTotal )  + ")"
RESULT True