PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WINDEV 24 → WD - Como fazer fSelectDir lembra o último diretório selecionado?
WD - Como fazer fSelectDir lembra o último diretório selecionado?
Iniciado por BOLLER ADRIANO, jul., 02 2016 5:40 AM - Sem resposta
Membro registado
2.949 mensagems
Popularité : +89 (91 votes)
Publicado em julho, 02 2016 - 5:40 AM
Voici le type de code que j`ai l`habitude d`utiliser pour réaliser ce traitement :
//INIT DE PROJET
//On vérifie dans le fichier INI si l`entrée RepCopieImage existe, sinon on l`affecte pas défaut
sCheminRepImage = INILit(RéseauUtilisateur, "RepCopieImage", "ERREUR", fRepEnCours()+"\ProViewer.ini")
SI sCheminRepImage = "ERREUR" ALORS
INIEcrit(RéseauUtilisateur, "RepCopieImage", "C:\", fRepEnCours()+"\ProViewer.ini")
FIN

//**************************************************************************************************

//CODE DU BOUTON
//Variables
sRepImages est une chaîne
sNouveauRep est une chaîne
sRepSelectionné est une chaîne

//Sélection du répertoire
sRepSelectionné = INILit(RéseauUtilisateur, "RepCopieImage", "ERREUR",fRepEnCours()+"\ProViewer.ini")
sNouveauRep = fRepSélecteur(sRepSelectionné,"Sélectionnez le répertoire des images à sauvegarder")

//mémorisation du nouveau chemin
SI sNouveauRep <> sRepSelectionné ALORS
SI PAS INIEcrit(RéseauUtilisateur, "RepCopieImage", sNouveauRep, fRepEnCours()+"\ProViewer.ini") ALORS
Info("Impossible de mémoriser le nom du répertoire de sauvegarde dans le fichier ProViewer.ini")
FIN
FIN


--
Adriano José Boller
______________________________________________
Consultor e Representante Oficial da
PcSoft no Brasil
+55 (41) 9949 1800
adrianoboller@gmail.com
skype: adrianoboller
http://wxinformatica.com.br/