PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WINDEV 24 → WD - Como controlar se o arquivo selecionado está bloqueado por outro processo?
WD - Como controlar se o arquivo selecionado está bloqueado por outro processo?
Iniciado por BOLLER ADRIANO, jul., 02 2016 5:51 AM - Sem resposta
Membro registado
2.962 mensagems
Popularité : +89 (91 votes)
Publicado em julho, 02 2016 - 5:51 AM
//Variables
NomFichierSel est une chaîne
nIdFic est un entier

//Séléction du fichier ZIP de reproduction
NomFichierSel=fSélecteur("", "", "Sélectionnez un fichier...", "Tous fichiers (*.*)"+TAB+"*.*", "*.*", fselOuvre + fselExiste)
SI NomFichierSel <> "" ALORS
nIdFic = fOuvre(NomFichierSel, foBloqueLecture + foBloqueEcriture)
SI nIdFic = -1 ALORS
Info("Le fichier est actuellement ouvert. Fermez le et recommencez sa sélection")
SINON
SI fFerme(nIdFic) = -1 ALORS
Info("Eerreur lors de la fermeture du fichier " + NomFichierSel)
SINON
//Le fichier n`est pas en cours de consultation
//Programmez le traitement voulu sur ce fichier
FIN
FIN
FIN


--
Adriano José Boller
______________________________________________
Consultor e Representante Oficial da
PcSoft no Brasil
+55 (41) 9949 1800
adrianoboller@gmail.com
skype: adrianoboller
http://wxinformatica.com.br/