PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WINDEV 24 → WD - Como criar dinamicamente o código interativo com W-Language?
WD - Como criar dinamicamente o código interativo com W-Language?
Iniciado por BOLLER ADRIANO, jul., 02 2016 6:00 AM - Sem resposta
Membro registado
2.962 mensagems
Popularité : +89 (91 votes)
Publicado em julho, 02 2016 - 6:00 AM
//Comment créer dynamiquement du code W-Langage

sResultatCompile est une chaîne
CodeACompiler est une chaîne =[
i est un entier
POUR i = 1 A 10
Info("Occurrence " + i + " de la boucle.")
FIN
]

sResultatCompile = Compile("MaProcédure",CodeACompiler)
SELON sResultatCompile
CAS "" : ExécuteTraitement("MaProcédure", trtProcedure)
CAS "ERR" : Info("Compilation impossible. "+RC+ErreurInfo())
AUTRE CAS
FIN
// Le code à compiler peut etre inclus dans un fichier texte externe
//dans ce cas on utilise la commande fChargeTexte() pour renseigner la variable CodeACompiler.


--
Adriano José Boller
______________________________________________
Consultor e Representante Oficial da
PcSoft no Brasil
+55 (41) 9949 1800
adrianoboller@gmail.com
skype: adrianoboller
http://wxinformatica.com.br/