PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WEBDEV 23 → Associer le nom à une couleur
Associer le nom à une couleur
Iniciado por anonyme, mai., 17 2018 3:24 PM - 2 respostas
Membro registado
85 mensagems
Publicado em maio, 17 2018 - 3:24 PM
(Re)Bonjour,

Je reviens vers vous suite à un problème. Cela fait suite à un sujet que j' avais posté précédemment:
https://forum.pcsoft.fr/fr-FR/pcsoft.fr.webdev/64851-prenom-non-trouve-dans-bdd/read.awp

Je veux associer un nom à une couleur dans un agenda. Le souci est que le nom n' est pas reconnu lorsque je teste, sur le site.

Voici mon code:
HLitRecherchePremier(RendezVous,IDRendezVous,nIDRDV)
SI HTrouve(RendezVous) ALORS
RendezVous.Titre = SAI_Titre
RendezVous.Contenu = SAI_Contenu
SELON sPrenom
CAS 1
sPrenom = "Toto"
RendezVous.CouleurDeFond = COULEUR_UTILISATEUR1 //jaune
CAS 2
sPrenom = "Tata"
RendezVous.CouleurDeFond = COULEUR_UTILISATEUR2 //vert
AUTRES CAS
RendezVous.CouleurDeFond = COULEUR_TRAVAIL //bleu
FIN


Voici le résultat
http://pasteall.org/pic/show.php…

Bizarrement, le sPrenom est reconnu dans mon header, mais pas dans l' agenda, faut-il le déclarer à nouveau ?

Merci d' avance.
Membro registado
412 mensagems
Publicado em maio, 17 2018 - 4:07 PM
Bonjour,

Essaye ca :
HLitRecherchePremier(RendezVous,IDRendezVous,nIDRDV)
SI HTrouve(RendezVous) ALORS
RendezVous.Titre = SAI_Titre
RendezVous.Contenu = SAI_Contenu
SELON sPrenom
CAS "Toto"
RendezVous.CouleurDeFond = COULEUR_UTILISATEUR1 //jaune
CAS "Tata"
RendezVous.CouleurDeFond = COULEUR_UTILISATEUR2 //vert
AUTRES CAS
RendezVous.CouleurDeFond = COULEUR_TRAVAIL //bleu
FIN


Jordan
Membro registado
85 mensagems
Publicado em maio, 17 2018 - 4:53 PM
Ça a marché, merci beaucoup !