PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WEBDEV 25 → Chargement Combo + Select dans ZR
Chargement Combo + Select dans ZR
Iniciado por Mademoiselle AUBERTOT, jun., 29 2020 4:42 PM - 1 resposta
Membro registado
27 mensagems
Publicado em junho, 29 2020 - 4:42 PM
Bonjour,

Contexte : création / update d'une facture, le détail des lignes de la facture s'affiche dans une zone répétée qui contient plusieurs listes déroulantes qui s'alimentent par programmation (lib affiché + ID en Glien). A la création, aucun problème, l'utilisateur sélectionne une ligne dans la combo et l'ID Glien est bien stocké en DB.

Problème : lorsque j'ouvre une facture en édition, la liste déroulante ne se charge pas correctement, j'arrive à l'alimenter avec les valeurs que je souhaite mais je n'arrive pas à sélectionner la bonne ligne en me basant sur l'ID stocké.

En dehors de la zone répétée je n'ai aucun problème pour faire la même chose (focus sur une ligne en particulier)

Avez-vous une solution pour contourner ce problème svp

Merci par avance !!
Julie

REQ_COUNTERPARTIES_ACCOUNT.pIDCounterparties = INVOICE.IDCounterparties
REQ_COUNTERPARTIES_ACCOUNT.pDate_validity = DateDuJour()
HExécuteRequête(REQ_COUNTERPARTIES_ACCOUNT)
HLitPremier(REQ_COUNTERPARTIES_ACCOUNT)
TANTQUE PAS HEnDehors(REQ_COUNTERPARTIES_ACCOUNT)
sTemp est une chaîne = REQ_COUNTERPARTIES_ACCOUNT.Quality + " - " + REQ_COUNTERPARTIES_ACCOUNT.Market + " - "+ REQ_COUNTERPARTIES_ACCOUNT.NumExternalAccount
ListeAjoute(COMBO_Account,sTemp + gLien(REQ_COUNTERPARTIES_ACCOUNT.IDAccount))
HLitSuivant(REQ_COUNTERPARTIES_ACCOUNT)
FIN


nIndice est un entier = 1
nIDINvoiceEnCours est un entier = TABLE_Invoice[TABLE_Invoice].COL_IDInvoice

REQ_INVOICE_DETAILS.pIDInvoice = nIDINvoiceEnCours
HExécuteRequête(REQ_INVOICE_DETAILS)
HLitPremier(REQ_INVOICE_DETAILS)
TANTQUE PAS HEnDehors(REQ_INVOICE_DETAILS)
ZoneRépétéeAjoute(ZR_InvoiceDetail)

ATT_Account[nIndice] = REQ_INVOICE_DETAILS.IDAccount
// ATT_Account --> COMBO_ACCOUNT

nIndice++
HLitSuivant(REQ_INVOICE_DETAILS)
FIN
Membro registado
260 mensagems
Popularité : +1 (1 vote)
Publicado em junho, 30 2020 - 8:25 AM
Bonjour Julie,
Il est possible que l'utilisation d'un gLien dans ce contexte ZR pose problème.

En supposant que dans la description de la ZR l'option permettant d'accéder aux propriétés des champs sans passer par les attributs soit cochée, peut-en pointant directement la combo dans la ZR ? :
ZR_InvoiceDetail[ZR_InvoiceDetail].COMBO_ACCOUNT = REQ_INVOICE_DETAILS.IDAccount


Cordialement

--
René MALKA