PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WINDEV (versões anteriores) → [WD24] Survol zone répétée
[WD24] Survol zone répétée
Iniciado por Philippe C., set., 03 2020 2:33 PM - 7 respostas
Membro registado
55 mensagems
Publicado em setembro, 03 2020 - 2:33 PM
Bonjour,

Je rencontre un phénomène bizarre chez un client avec une zone répétée.
Celle-ci n'est pas bien compliqué, elle est constituée d'un champ image et d'un champ texte invisible contenant un code par rapport à l'image chargée.

Après avoir sélectionné une image dans la zone répétée, le survol sur les autres remplace l'image présente pas celle sélectionnée...

Je ne vois pas comme ça ce qui peux causer ce problème, surtout que je ne sais pas reproduire l'erreur.
Je viens de migrer d'une version 20 et il n'y avait pas ce souci avant...

Merci pour les retours éventuels.


Bon après-midi,
Publicado em março, 30 2021 - 7:15 PM
Bonjour,
J'ai le même souci mais avec un tableau dans une zone répétée.
Au survol de la souris sur les zones précédent ma zone sélectionnée, tous mes tableaux se changent en celui qui est sélectionné. Il ne s'agit que d'un souci d'affichage mais c'est très perturbant.
Et je n'ai pas trouvé comment le régler
Merci pour votre aide et vos réponses
Membro registado
55 mensagems
Publicado em março, 31 2021 - 8:39 AM
Bonjour,

Pour les images j'ai réussi à trouver une parade...

Au niveau de table dans une zone répétée nous avions aussi un phénomène similaire.
Le problème venait du fait que nous rechargions la zone répétée après un clic sur la table.
L'élément en cours étant détruit et rechargé pendant le clic, la zone répétée n'appréciait pas trop...

Ce problème n'était par contre pas présent en WinDev 20, nous avons eu toutes ses erreurs suite à notre migration en 24.


Bien à vous,
Publicado em abril, 07 2021 - 6:25 PM
Merci pour votre réponse.

Mais j'ai vérifié et je ne rafraichis pas ma zone répétée.
J'ai refait des tests :
- affichage zone répétée avec les tableaux --> plusieurs pages remplies donc affichage de l'ascenseur vertical
- clic dans un tableau de la 1ère page, survol souris --> rien d'anormal
- clic dans un tableau en bas de la 2ème page, je ne bouge plus la souris et scroll roulette :
- pour descendre dans les pages suivantes --> nickel
- pour remonter dans la page précédente --> sans avoir bougé la souris toute la page affiche le contenu du tableau sélectionné avec le bandeau sur la ligne sélectionnée

Il semblerait que la gestion de l'ascenseur vers le haut avec l'affichage de zone rencontre des problèmes.
La gestion de l'affichage quand on va vers le bas fonctionne très bien.
Membro registado
55 mensagems
Publicado em abril, 07 2021 - 10:20 PM
Bonjour,

Oui, nous avions exactement le même phénomène.

La personne avec qui j'ai regardé à ça est en congé, je lui demande courant de semaine prochaine et je vous reviens si nous avons la solution miracle.


Bien a vous,
Membro registado
55 mensagems
Publicado em abril, 08 2021 - 2:04 PM
Bonjour,

J'ai regardé dans le projet concerné afin de voir si quelque chose me sautait aux yeux.

Je vois que nous avons ajouté à l'époque un fenRepeint() dans la zone répétée sur les événements :
- Ascenseur Vertical.
- Roulette souris.

Je ne vois rien d'autre :(


Bien à vous,
Publicado em abril, 08 2021 - 3:16 PM
Bonjour,

Merci pour retour.
Je viens d'essayer mais pas mieux.
J'avais aussi tenté ..AffichageActif sur survol, roulette souris et ascenseur vertical mais sans succès.

Si votre collègue a d'autres pistes je suis preneuse.
Bonne journée
Membro registado
55 mensagems
Publicado em abril, 08 2021 - 4:03 PM
ça aurait été trop beau :(

Je lui demande mardi (je suis en congé lundi).

Je vous tiens au courant.