PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WINDEV Mobile (versões anteriores) → [WM20] Supprimer des fichiers téléchargés en FTP
[WM20] Supprimer des fichiers téléchargés en FTP
Iniciado por Shanks, set., 27 2018 8:41 AM - 1 resposta
Membro registado
8 mensagems
Publicado em setembro, 27 2018 - 8:41 AM
Bonjour à tous,

Je suis actuellement sur le développement d'une application permettant l'affichage de fichiers PDF.
Ces derniers sont récupérés via FTP depuis nos serveurs de cette façon :
nIdco est un entier = FTPConnecte("*****", "*****", "*****", 21, Vrai, 60)
SI nIdco <> -1 ALORS
nEtat est un entier = SysEtatCarteStockage()
sRep est une chaîne
SI nEtat = sysCarteDisponible ALORS
sRep = SysRepCarteStockage()+"/Download"
SI PAS fFichierExiste(sRep+[fSep]+TABLE_Fichiers.COL_Nom_FUT) ALORS
FTPRécupère(nIdco, [fSep]+"Files"+[fSep]+TABLE_Fichiers.COL_Nom_FUT, sRep, "Jauge_Transfert")
FTPDéconnecte(nIdco)
FIN
FIN
LanceAppliAssociée(sRep+[fSep]+TABLE_Fichiers.COL_Nom_FUT)
SINON
Info("Connexion échouée.")
FIN
FIN

J'ai la même chose pour récupérer un APK servant à mettre à jour l'application.
A la déconnexion de l'utilisateur je souhaite effacer tous les fichiers qu'il a téléchargé (ce sont des tablettes pour chauffeurs routiers, elles changent donc de mains régulièrement.)
Et là je n'y arrive pas :/
Les fichiers sont enregistrés dans "/storage/emulated/10/Download" (Merci adobe qui me montre le chemin des fichiers.
Dans les paramètres de stockage je vois le volume augmenter mais quand je clique dessus il me dit qu'il n'y a rien.
Et mon objectif est que ce soit l'application qui supprime et non l'utilisateur.
Voici ce que j'ai essayé à la déconnexion de l'utilisateur :
// 1
UnFichier1, ResListeFichier1 sont des chaînes
ResListeFichier1 = fListeFichier("/storage/emulated/10/Download")
// Pour chaque fichier trouvé
POUR TOUTE chaîne UnFichier1 de ResListeFichier1 SEPAREE PAR RC
fSupprime(UnFichier1, frLectureSeule)
FIN
// 2
UnFichier2, ResListeFichier2 sont des chaînes
ResListeFichier2 = fListeFichier("/sdcard/Download")
// Pour chaque fichier trouvé
POUR TOUTE chaîne UnFichier2 de ResListeFichier2 SEPAREE PAR RC
fSupprime(UnFichier2, frLectureSeule)
FIN
// 3
nEtat est un entier = SysEtatCarteStockage()
sRep est une chaîne
SI nEtat = sysCarteDisponible ALORS
sRep = SysRepCarteStockage()+"/Download"
UnFichier3, ResListeFichier3 sont des chaînes
ResListeFichier3 = fListeFichier(sRep)
// Pour chaque fichier trouvé
POUR TOUTE chaîne UnFichier3 de ResListeFichier3 SEPAREE PAR RC
fSupprime(UnFichier3,frLectureSeule)
FIN
FIN
// 4
fListeFichier(SysRepCarteStockage()+"/Download", "Supp_File")
fListeFichier("/storage/emulated/10/Download", "Supp_File")
fListeFichier("/storage/emulated/0/Download", "Supp_File")
fListeFichier("/sdcard/Download", "Supp_File")

Procedure PRIVÉE Supp_File(sChemin, sNom)
fSupprime(sChemin+sNom, frLectureSeule)
RENVOYER Vrai


Vous l'aurez compris rien ne fonctionne :(

Je vous remercie d'avance pour votre aide !
Mensagem modificada, setembro, 27 2018 - 8:43 AM
Membro registado
8 mensagems
Publicado em outubro, 02 2018 - 4:05 PM
J'ai bidouillé un bout de code java qui fonctionne à merveille.
Merci quand même et bon dev à tous.