PC SOFT

GRUPOS DE DISCUSSÃO PROFISSIONAL
WINDEVWEBDEV e WINDEV Mobile

Inicio → WINDEV 24 → Deploy Windev App with MS Access database - Error 7
Deploy Windev App with MS Access database - Error 7
Iniciado por skippy, dez., 12 2019 11:45 PM - 2 respostas
Membro registado
17 mensagems
Publicado em dezembro, 12 2019 - 11:45 PM
Hi,

I have an application using a Microsoft Access Database. I create the Executable and copy the whole Exe Folder to another PC. I always get the error

------------------------------------------------------
HReadFirst function called.
The <QRY_Module> data source is not initialized.
- If it is a data file, the file was not found in the <C:\My Projects\UVPReport\UVPReport.wdd> analysis or it was not described by HDeclare/HDeclareExternal.
- If it is a query or a view, the execution may have failed.
To retrieve the corresponding error, check the result of HExecuteQuery/HExecuteSQLQuery/HCreateView.

Error code: 70018
Level: fatal error
WD55 error code: 18

Dump of the error of 'wd240hf64.dll' module (24.0.170.0).
Identifier of detailed information (.err): 70116
Debugging information:
IEWDHF=1.20
Module=<WDHF>
Version=<24.0.170.0>
Fonction (7,10)
Additional information:
EIT_PATHWDD : <C:\My Projects\UVPReport\UVPReport.wdd>
EIT_LOGICALTABLENAME : <QRY_Module>
EIT_PILEWL :
Click BTN_GoRelease (WIN_UVP.BTN_GoRelease), line 8
End of initialization of WIN_UVP (WIN_UVP), line 8
EIT_DATEHEURE : 12/12/2019 22:58:32
EIT_TYPE_WDFILE : <2>

------------------------------------------------------

The detailed information:
------------------------------------------------------
73001: OLE DB access error.<\r><\n>Error Number = 170124 <\r><\n> <\r><\n>Failure opening connection:<\r><\n>Data Source: <D:\Synology\Drive\WinDev\Exe\ReleaseInfo.accdb><\r><\n>OLEDB Provider: <Microsoft.ACE.OLEDB.12.0><\r><\n><\r><\n>System error details:<\r><\n><TAB>Description = Der Provider kann nicht gefunden werden. Möglicherweise ist er nicht richtig installiert worden.<\r><\n><TAB>Source = ADODB.Connection<\r><\n><TAB>Help File = C:\WINDOWS\HELP\ADO270.CHM<\r><\n><TAB>Help Context = 1240655 (0x12ee4f)<\r><\n><TAB>Error Number = -2146824582 (0x800a0e7a)<\r><\n>
------------------------------------------------------

I have played aroud with many things now and I can't catch the problem. It seems that the exe file refers to the original path of the different components and so the file in the original project folder can't be found.

I assume I'm not the first one who deploys the exe in that way, so I seem to miss something fundamental.

Please can anyone give a useful hint to solve that problem ? I'm really frustrated as I can't find any solution.

Thanks
skippy

--
Windev, WinMobile & WebDev 24
Publicado em dezembro, 31 2019 - 4:21 AM
I've just begun to work with the WD product (so take it for what it is worth), 'the Error Number = -2146824582 (0x800a0e7a)'
is a connection string error (meaning db not found)... seen this in other situations with different products many times. Don't know how to fix it in your instance but, try setting up an ODBC connection in Windows to see if it can actual open the *.mdb/*.accdb file for communication and or corruption. Worth a try...
Publicado em dezembro, 31 2019 - 4:25 AM