PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV 25 → Boucles de parcours imbriquées
Boucles de parcours imbriquées
Started by CmoiAlain, Dec., 11 2019 11:34 AM - 5 replies
Posted on December, 11 2019 - 11:34 AM
Bonjour,

Je parcours une table afin de mettre en évidence les cellules dont la valeur est négative, le code ci-dessous fonctionne parfaitement.
J'imbrique donc deux boucles de parcours, lignes et colonnes, mais peut on éviter cela en ne faisant qu'une boucle ?
nligne, nColonne est un entier

POUR nligne = 1 _A_ TableOccurrence(TableResutats) // Parcours de chaque ligne
POUR nColonne = 1 _A_ TableOccurrence(TableResutats, toColonne) // Parcours de chaque colonne
SI TableResutats[nligne,nColonne] < 0
TableResutats[nligne,nColonne]..CouleurFond = RougeClair
TableResutats[nligne,nColonne]..Couleur = Blanc
SINON
TableResutats[nligne,nColonne]..Couleur = Blanc
TableResutats[nligne,nColonne]..Couleur = Noir
FIN
FIN
FIN


Merci de votre aide
Alain
Registered member
5 messages
Posted on December, 11 2019 - 9:51 PM
Si pas trop de colonne, peut etre une piste,
en passage de param de procedures ligne,colonnne pour mise ne couleur

POUR TOUTE LIGNE DE TABLE_Utilisateur
si col_1 < 0 Alors Netagive (pos_ligne,col_1) sinon Positive(pos_ligne,col_1)
si col_ 2 < 0 Alors Netagive (pos_ligne,col_ 2) sinon Positive(pos_ligne,col_ 2)
.....
.....
FIN
A creuser et tu n'as qu'une boucle.
Posted on December, 13 2019 - 9:18 AM
Bonjour,

Merci pour la réponse.
Je vais regarder ça.

Bon dev
Alain
Posted on December, 13 2019 - 2:41 PM
Bonjour

Sans programmation, en utilisant eyeMagnet par colonne concernée.
Posted on December, 14 2019 - 12:25 PM
Bonjour,

C'est vrai, les eyeMagnet font également très bien le job mais je préfère le coder, mon coté parano vraisemblablement...

Merci

Bon dev
Alain
Registered member
14 messages
Posted on May, 03 2020 - 5:05 PM
Bonjour Alain,

Je suis débutant en Windev et je cherche tout simplement à changer les fonds de couleur d'une table en fonction de conditions.
Ca semble bête, mais je ne vois pas comment boucler sur la table....comment instancier la ligne ou la colonne lue etc...
Je suis sur le code de ma table dans la section affichage ligne, mais ensuite ???
Comment faire ?
Quelle est l'instruction qui lit la 1ère ligne d'une table ? quelle instruction pour lire le suivant ? etc...

Merci d'avance pour ton retour,