PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV 2024 → saisie avec prediction adresse postale
saisie avec prediction adresse postale
Started by Laurent, Dec., 01 2023 5:48 PM - 1 reply
Registered member
222 messages
Posted on December, 01 2023 - 5:48 PM
bonjour

à partir du champs métier "saisie avec prediction adresses postales", comment récuperer dans des champs le numéro, le nom de la rue...

merci

--
LH
Posted on December, 02 2023 - 9:14 AM
Laurent a pensé très fort :
bonjour

à partir du champs métier "saisie avec prediction adresses postales", comment
récuperer dans des champs le numéro, le nom de la rue...

merci


Normalement quand tu reçois la réponse de google map cela donner ceci

POUR TOUT resultAd DE jsonDétails.result.address_components
SELON resultAd.Types[1]
CAS "route" : sAdresseGoogle.sRue = resultAd.long_name
CAS "street_number" : sAdresseGoogle.sNumRue = resultAd.long_name
CAS "locality" : sAdresseGoogle.sVille = resultAd.long_name
CAS "country" : sAdresseGoogle.sPays = resultAd.long_name
CAS "postal_code" : sAdresseGoogle.sCodePostal = resultAd.long_name
AUTRE CAS
FIN
sAdresseGoogle.sLibelle = jsonDétails.result.formatted_address
sAdresseGoogle.Latitude = jsonDétails.result.geometry.location.lat
sAdresseGoogle.Longitude = jsonDétails.result.geometry.location.lng
FIN

BAT