PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV Mobile 26 → Liste fichier du répertoire photo
Liste fichier du répertoire photo
Started by Stéphane D., Nov., 24 2021 3:32 PM - 4 replies
Registered member
127 messages
Posted on November, 24 2021 - 3:32 PM
Bonjour à tous,
Je voudrais énumérer la liste des photos prise sur la carte SD de la tablette.
Voici mon bout de code :
UnFichier, ResListeFichier, monChemin sont des chaînes

monChemin = SysRepStockageExterne(2,ssePublic)+"/DCM/Camera/"
Info(monChemin) //J'ai bien /storage/5C2F-EC2B/DCM/Camera

ResListeFichier = fListeFichier(gsRepLocalEncours)

Info(ResListeFichier) //La liste est vide

POUR TOUTE chaîne UnFichier de ResListeFichier SEPAREE PAR RC
Info(UnFichier)
FIN

Si quelqu'un pouvez m'orienter
Je suis en version 25.
Merci d'avance de votre aide.

--
Stéphane.
Registered member
127 messages
Posted on November, 24 2021 - 3:34 PM
Dsl j'ai bien mis cela :
monChemin = SysRepStockageExterne(2,ssePublic)+"/DCM/Camera/"
Info(monChemin) //J'ai bien /storage/5C2F-EC2B/DCM/Camera

ResListeFichier = fListeFichier(monChemin)

Info(ResListeFichier) //La liste est vide

POUR TOUTE chaîne UnFichier de ResListeFichier SEPAREE PAR RC
Info(UnFichier)
FIN


--
Stéphane.
Posted on November, 25 2021 - 12:13 PM
Bonjour,

Vous ne précisez pas sur quelle version d'Android est exécuté votre code.
Sachez qu'il existe de nouvelles restrictions depuis Android 10, je vous invite à aller consulter cette page : https://doc.pcsoft.fr/fr-fr/?1000021793&name=sysrepstockageexterne_fonction (Gestion des fichiers et de leur emplacement).

Cordialement,
Registered member
127 messages
Posted on November, 25 2021 - 5:16 PM
Bonjour Aurélie,
Je vous remercie de votre réponse.
Je vais aller voir votre lien, et je suis en version 25.

--
Stéphane.
Registered member
127 messages
Posted on November, 25 2021 - 5:44 PM
Je suis trop...
J'ai juste oublié un I pour le répertoire DCIM et non pas DCM....

--
Stéphane.