PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV Mobile (earlier versions) → Problèmes avec une procédure stockée
Problèmes avec une procédure stockée
Started by DEKPON Renaud Silvèr, Sep., 02 2020 11:59 PM - No answer
Registered member
5 messages
Posted on September, 02 2020 - 11:59 PM
Bonsoir, j'ai une difficulté avec les procédures stockées. J'ai un projet fait en windev mobile 22 qui utilise une bd Hyperfile client serveur avec laquelle il communique via les procedures. Le souci c'est que l'une des procédures me casse la tête à l'exécution via la fonction hexecuteprocedure alors qu'en mode débogage, il fonctionne parfaitement. A l'exécution, l'appel de la fonction déclenche un bug. Les détails n'étant pas facilement identifiables avec une procédure stockée, toujours est il que l'erreur est renvoyé par le serveur. Il faut noter que les fichiers fichiers hyperfile sont tous cryptés et que la fonction hpasse a été utilisé dans le code de déclaration des globale de la collection de procédures. Ci-après le code de ma procédure :


PROCEDURE ajoute_et_modifie_profs(sNom_prof est une chaîne,nAccessysteme est un entier,id est un entier sur 8 octets=0,codesecret est une chaîne="")

SI id=0//Mode ajoutd=0 ALORS
Professeur.Nometprenom=sNom_prof
Professeur.acces_systeme=nAccessysteme
Professeur.codesecret=codesecret
HAjoute(Professeur)
RENVOYER liste_profs()
SINON//mode modifie
HLitRecherche(Professeur,IDProfesseur,id)
SI HTrouve(Professeur) ALORS
SI codesecret<>"" ALORS
Professeur.codesecret=codesecret
FIN
Professeur.acces_systeme=nAccessysteme
Professeur.Nometprenom=sNom_prof
HModifie(Professeur)
RENVOYER liste_profs()
FIN
FIN
RENVOYER ""