PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WINDEV Mobile 2024 → configuration de WMIOSBuild64.exe
configuration de WMIOSBuild64.exe
Iniciado por Jean Turcotte, 13,sep. 2022 17:23 - 11 respuestas
Miembro registrado
1.095 mensajes
Popularité : +8 (8 votes)
Publicado el 13,septiembre 2022 - 17:23
Bonjour, j'essaie de compiler mon appli en IOS en utilisant WMIOSBuild64.exe mais je ne suis pas capable de me connecter à ma station MAC, j'ai toujours une erreur de connexion. Notez que j'ai activé la session à distance sur mon MAC.




Voici ma fenêtre de config.




J'ai essayé plein de différente config mais rien ne semble fonctionner.

Des idées?
Merci!

--
Jean Turcotte
WX 27
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
34 mensajes
Publicado el 16,marzo 2023 - 08:14
Bonjour,
Avez vous réussi à vous connecter, car moi aussi je me casse les dents dessus.;(
J' arrive avec MS config de mon PC, mais je dois mettre quoi dans la boite de dialogue Edition du poste MacOS.

J'ai tout essayé, ....Help






Au plaisir d'échanger avec vous.

--
En programmation, rien ne sert de soulever des montages quand on peut les contourner...
Miembro registrado
34 mensajes
Publicado el 16,marzo 2023 - 08:18
Re-bonjour

J'ai aussi ce retour :





Je cherche, je test, et j'échoue }:(

--
En programmation, rien ne sert de soulever des montages quand on peut les contourner...
Publicado el 16,marzo 2023 - 08:53
Bonjour je suis dans le même cas, j'ai abandonné et refait la navette entre mon pc et mon mac.
Miembro registrado
42 mensajes
Publicado el 16,marzo 2023 - 10:07
Même erreur, je n'ai jamais réussit le faire fonctionner.
J'avais ouvert un ticket support mais sans résultat : ça marche chez eux... mais je vois que ne suis pas le seul.
En ssh avec PuTTy la connexion se fait bien sur mon mac...

A faire remonter au support

--
Développeur sur https://www.emjysoft.com/
Mensaje modificado, 16,marzo 2023 - 10:08
Miembro registrado
462 mensajes
Popularité : +20 (20 votes)
Publicado el 16,marzo 2023 - 12:50
un correctif pour la 27 a été fourni en aout 2022 ...
Voici un lien vers une mise à jour de cet utilitaire (version 64 bits)
https://stg.webdev.info/Telechargement_Support_WEB/FR/telec_ST.awp…
Miembro registrado
34 mensajes
Publicado el 17,marzo 2023 - 14:20
Bonjour,
j ai installé le correctif et fais des essais.
Il me demande d'installer les outils developer "Command Line Developer Tools", ce que j'ai fait.

Peut importe les paramètres que je mets j'ai toujours ce message:





Et bizarrerie, sans être relié en Lan au Mac, j'ai eu le même message !!!!!

Comment il peut mettre ce message, alors que je suis pas en réseau.

Pour l'erreur de connexion : OK
Mais me renvoyer une erreur Xcode du Mac, si pas connecté au mac alors la, je comprends pas !!!!
C'est un message par défaut ou quoi ?

Si quelqu'un a réussi a faire fonctionner cet utilitaire, ou il sait comment s'y prendre pour connecter ou mettre XCode à niveau, aidez moi !!!
Ou m'éclaircir sur les paramètres à utiliser peut-être...

Merci d'avance de votre aide

--
En programmation, rien ne sert de soulever des montages quand on peut les contourner...
Miembro registrado
42 mensajes
Publicado el 17,marzo 2023 - 16:04
Même problème et même message avec le correctif. comme dit par Willf974
Miembro registrado
34 mensajes
Publicado el 18,marzo 2023 - 02:34
Bonjour,

Vers mon MAC
J'ai fait un ping <ip> , perte 0%
j'ai fait un tracert <ip>, itinéraire déterminé.
J'ai fait un portqry -n <ip> -p both -e <port>, et retour de message : port filtré !!!!

Du coup, je passe sur Mac BooK Air M1 OS Ventura version 13.2.1
Pomme ->Réseau -> Coupe feu -> <activé> - > options -> Connexion à distance (SSH) <Autoriser les connexions entrantes>
Je rajoute pour Xcode avec le +

Je refais portqry, et port 22 listening.

Je passe sur le terminal MAC, pour tenter de désinstaller et réinstaller "Command Line Developer Tools" car j'arrive pas à traiter le message de l'utilitaire :
xcode-select: error : command line tools are already installed, use "Software Update" in System Setting to install updates.

Faut que j'arrive à faire ce update, je pense.
P.S: la commande pour l'installer le " Command ..." -> xcode-select --install

Si quelqu'un connait la commande Update pour le terminal : xcode-select --update ne fonctionne pas.


On va y arriver à faire fonctionner ça quand même.

Voila, je remets les mains dedans ce matin .

--
En programmation, rien ne sert de soulever des montages quand on peut les contourner...
Miembro registrado
34 mensajes
Publicado el 18,marzo 2023 - 03:34
Bonjour

Bon alors pour la mise jour de Command Line Tools:

Exécutez dans le terminal MAC :

softwareupdate --all --install --force

si vous avez le message :
No updates are available..

Cela vous montre aucune mise à jour, exécutez :

Pour supprimer CommandLineTools :

sudo rm -rf /Library/Developer/CommandLineTools

Si vous lancez WMIOSBuild, il vous demande la mise a jour, et d'accepter celle ci sur Mac (a ce stade tout se passe bien, et après l'install, si vous faites Tester avec WMIOSBuild, il mouline et affiche son message d'erreur habituel.

Autres méthodes pour reinstaller CommandLineTools :

sudo xcode-select --install

Et pour l'instant, même si WMIOSBuild, demande à executer l'installation, il me remets le même message d'erreur .

--
En programmation, rien ne sert de soulever des montages quand on peut les contourner...
Miembro registrado
3.270 mensajes
Popularité : +93 (137 votes)
Publicado el 18,marzo 2023 - 11:49
Salut @Willf974,
Je pense que ton soucis vient du fait que ton mac est M1
A vérifier auprès de pcsoft si l'outil WMIOSBuild est compatible avec ce processeur.
Miembro registrado
34 mensajes
Publicado el 18,marzo 2023 - 16:35
Salut @Popoy,

Je pense aussi a la puce M1, je vais de ce pas soumettre un ticket au ST de Pc Soft.

Si d'autres personnes ont des pistes , n'hésitez pas.

--
En programmation, rien ne sert de soulever des montages quand on peut les contourner...