PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile (précédentes versions) → [WD20] - données absentes de l'APK
[WD20] - données absentes de l'APK
Débuté par xdeslandes, 12 sep. 2018 18:09 - 13 réponses
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 12 septembre 2018 - 18:09
Bonjour,

J'ai créé une appli avec des données embarquées HFSQL. Pas de souci.
J'ai voulu créer une appli "version LITE" (avec un peu moins de fonctionnalités). J'ai donc fait un copier-coller du projet.

Malheureusement, lorsque je génère l'application, les fichiers de données (.fic, .ndx de mémoire) ne semblent pas être incorporés dans l'APK (bien qu'ils soient cochés dans la génération).

Le Go est parfait. Mais une fois l'appli déployée sur une tablette, les données semblent absentes.

Je ne vois pas dans quelle direction chercher ou quel test faire pour m'assurer que ces fichiers soient bien embarqués dans l'APK

Merci pour vos tuyaux.

--
Merci !
Xavier.
Posté le 06 novembre 2018 - 18:34
Si ce n'est pas fait, Il faut inclure les fichiers fic et ndx au moment de la génération de l'APK. C'est l'une des étapes proposé lors de la génération
Posté le 06 novembre 2018 - 18:34
Si ce n'est pas fait, Il faut inclure les fichiers fic et ndx au moment de la génération de l'APK. C'est l'une des étapes proposé lors de la génération
Posté le 07 novembre 2018 - 10:11
Bonjour Thomas, et merci.
Bien entendu, c'est fait (mal ?). Dans l'étape de génération de l'appli, on voit bien que ces fichiers sont inclus. mais ils sont visiblement importés dans le mauvais dossier: mes données ne sont pas accessibles sur le terminal.
Posté le 07 novembre 2018 - 20:11
pour ma part je met cela en début de projet Windev mobile.
HChangeRep("*",fRepDonnées())
HModifieStructure("*")
HCréationSiInexistant("*")


Aussi, il faut bien procéder à la suppression des données de l'appli sur le smartphone (Depuis le menu application d'Android / Effacer les donnée)
Posté le 08 novembre 2018 - 09:13
Merci Thomas, je vais tenter cela ce soir.
Mais pourquoi "procéder à la suppression des données de l'appli sur le smartphone" ?
Posté le 08 novembre 2018 - 13:53
Je procède ainsi afin d'être sur que les fichiers HF contenu dans l'apk à la génération soit présent sur le smartphone lors du déploiement.

Si'il sont déjà présent, ils ne sont pas remplacés.
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 09 novembre 2018 - 11:13
Hélas, cela ne fonctionne pas.
Dans mon étape d'installation j'ai:





Et j'ai fait indiquer à l'appli l'endroit où ces fichiers étaient stockés en faisant
// test
sRep_fichiers est une chaîne = ComplèteRep(fRepEnCours())
LIB_ressources = sRep_fichiers

et l'appli (exécutée sur tablette) m'indique:
/data/user/0/<mon package>/files/

Help.

--
Merci !
Xavier.
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 28 novembre 2018 - 15:41
Pourquoi n'ai je pas de réponse ? Mon cas est isolé ?

--
Merci !
Xavier.
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 28 novembre 2018 - 17:45
Grâce à un
sRepDonnees est une chaîne = fRepDonnées()
LIB_ressources += RC + sRepDonnees

Je lis sur la tablette
/data/user/0/<mon package>/databases

--
Merci !
Xavier.
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 02 avril 2019 - 11:03
Je poursuis ce sujet !! Je n'ai toujours pas résolu mon souci.

Lorsque je fais afficher le résultat d'un "fListeRessource", il n'y a rien !
Où sont mes data ?

--
Merci !
Xavier.
Membre enregistré
17 messages
Posté le 04 avril 2019 - 15:33
Bonjour.

Essaye de voir avec cette aide si ça peux te servir :
https://doc.windev.com/fr-FR/…
Et celle-ci : https://doc.windev.com/fr-FR/…
--
Cordialement
Message modifié, 04 avril 2019 - 15:34
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 04 avril 2019 - 17:57
J'ai fait quelques modifs: fListeRessource me liste bien mes fichiers .fic, .ndx et .mmo (conformément à l'étape de compilation du projet), mais ces fichiers semblent vides !

Toujours pas de solution.

Merci pour la documentation.

--
Merci !
Xavier.
Membre enregistré
149 messages
Popularité : +1 (1 vote)
Posté le 29 avril 2019 - 11:09
J'ai tout essayé !!
Incroyable, on dirait que mon cas est isolé !
C'est un truc de fou de ne pas pouvoir obtenir d'aide.

Tout fonctionne sur l'émulateur (sur le PC), mais les données ne sont pas transmises sur le device mobile (ex.tablette).

QUE DOIS-JE FAIRE ?

Merci pour votre aide. Je ne peux plus avancer sans vous désormais.

--
Merci !
Xavier.