PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV 24 → HTML Control
HTML Control
Started by skippy, Oct., 10 2019 11:20 PM - No answer
Registered member
16 messages
Posted on October, 10 2019 - 11:20 PM
I have an HTML Control in Runtime Mode "Latest Version of IE / Edge". My assumption is that it should behave just like IE or Edge because of my assumption that it uses the existing IE/Edge control.
Now, I have a very simple HTML file with an Image and a CSS in the same folder (exe folder of the windev application) and it shows nicely in edge. Image and CSS found and rendered.
When I run my application, loading the same html file into the html control, then it can't find neither the CSS file nor the Image.
The files are refereneced in the html file without path, like "example.css" and as stated above, the application can't find it but edge can.
When I put the full path (like C:\somewhere\example.css" into the html, it can find and render both. But of course I don't want to use it like that, when I distribute the application. However, even then, rendering it by using the full path, it still doesn't behave like edge, because edge centers the image *and* the text (according to the css) while the windev application only centers the text and not the image. Also, edge is resizing the image, which is not done by the application.

I'm wondering why this is and what I can do about it. Any idea ?

Thanks
skippy

PS: I have set the current dir to the exe folder, didn't help. I also considered using a chrome control project (CEF) which I found here in the forum, but it didn't work ootb.

--
Windev, WinMobile & WebDev 24