PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → Hors-sujet → CALCULATRICE
CALCULATRICE
Débuté par Jeancy TOUNGOU, 02 juin 2021 09:11 - 2 réponses
Membre enregistré
1 message
Posté le 02 juin 2021 - 09:11
bonjour,
j'ai créée une calculatrice,mais je n'arrive pas à créer une touche qui peut qu'effacer ou supprimer
que le dernier chiffres.
Pouvez-vous m'aider svp?quels sont les codes sources à utiliser?
Posté le 02 juin 2021 - 16:42
Bonjour,
Pour faire ça, j'ai créé un bouton avec un libellé "<-" sur mon pavé de calculatrice.





Sur l'évènement "Clic" des boutons,de la calculatrice, j'appelle une fonction locale qui agit selon le libellé du bouton cliqué : RemplirQuantite(MoiMême..Libellé). En l'occurrence, le CAS ">-" prend la chaine existante, supprime le dernier caractère à droite de cette chaine, puis le renvoie à la zone de saisie/affichage de la valeur prise en compte( sai_quantite). Les valeurs numériques sont transformées en chaine avant traitement, pour pouvoir utiliser la fonction Droite()
PROCÉDURE RemplirQuantite(Valeur est une chaîne)

sQte est une chaîne = SAI_Quantité
rQte est un réel

SELON Valeur
CAS ","
SI ChaîneOccurrence(sQte,Valeur) > 0 ALORS RETOUR
sQte = sQte+Valeur+"0"
gbVirguleSaisie = Vrai
CAS "<-"
sQte = Gauche(sQte,Taille(sQte)-1)
CAS "-/+"
SI ChaîneOccurrence(sQte,"-") > 0 ALORS
sQte = Droite(sQte,Taille(sQte)-1)
SINON
sQte = "-" + sQte
FIN
CAS "C"
sQte = ""
AUTRES CAS
SI gbVirguleSaisie ALORS
rQte = Val(sQte)+(Val(Valeur)/10)
sQte = NumériqueVersChaîne(rQte,"5.1F")
gbVirguleSaisie = Faux
SINON
sQte = sQte+Valeur
FIN
FIN

SAI_Quantité = sQte


Il y a surement mieux à faire, mais ça marche...
Membre enregistré
815 messages
Popularité : +2 (2 votes)
Posté le 10 juin 2021 - 17:01
Bonjour,
Uniquement pour le dernier chiffre je ferais quelque comme :
sMaSaisie est chaîne=SAI_Monétaire
nTaille est un entier=Taille(sMaSaisie)-1
SAI_Monétaire=sMaSaisie[1 À nTaille]


--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube