PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV (précédentes versions) → Bonjour j'utilise la version 22 de WEBDEV
Bonjour j'utilise la version 22 de WEBDEV
Débuté par Salvador, 18 avr. 2018 14:50 - 1 réponse
Membre enregistré
1 message
Posté le 18 avril 2018 - 14:50
Bonjour j'utilise la version 22 de WEBDEV, et j'ai conçu une appli qui est déjà hébergée dans laquelle j'utilise un bouton Imprimer me permettant de voir différentes infos de ma table. Je précise que le code marche bien, mais le souci est que le même bouton ne marche pas lorsque j'essaie cette fois ci de voir le même état à partir de mon smart phone Android.
Merci de m'aider.
cordialement

Voici le code
//////////////////////////////////
bRep est un booléen
bRep=Faux


InitHasard()
chaineAléatoire est une chaîne
BOUCLE(27)
ncaractere est un entier = Hasard(65,122)
TANTQUE (91 <= ncaractere <= 96)
ncaractere = Hasard(65,122)
FIN
chaineAléatoire += Caract(ncaractere)
FIN

sFichierapercu est une chaîne = fRepWeb()+"\"+DateSys()+ HeureSys()+".PDF"

SI PAS HExécuteRequête(REQ_detail_dmd_par_dmd,hRequêteDéfaut,ZR_table_demande.ATT_code) ALORS
SINON
iDestination(iPDF,sFichierapercu)
iInitRequêteEtat(ETAT_Bon_cmd_struct1,ZR_table_demande.ATT_code)
iImprimeEtat(ETAT_Bon_cmd_struct1)
bRep=Vrai
FIN

SI bRep=Vrai ALORS
LanceAppliAssociée(sFichierapercu)
FIN
Message modifié, 18 avril 2018 - 14:51
Membre enregistré
685 messages
Popularité : +3 (3 votes)
Posté le 26 avril 2018 - 15:13
Je pense que vous naviguez sur votre site directement depuis le serveur web ? Ou poste développement ?
Essayez depuis un autre pc et vous aurez le même phénomène que sur le smartphone :

SI bRep=Vrai ALORS
LanceAppliAssociée(sFichierapercu)
FIN


LanceAppliAssociée permet d'ouvrir effectivement le PDF .. SUR LE POSTE qui exécute le code, autrement dit, le serveur web (ou poste développement).. bref le poste sur lequel tourne le serveur d'application.

Ce n'est pas le but recherché. Il faut plutôt faire :


SI bRep=Vrai ALORS
FichierAffiche(sFichierapercu)
FIN


Ainsi, le serveur web renverra au navigateur le fichier, lui permettant de le télécharger.