PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV (précédentes versions) → WEBSERVICE REST dans WEBDEV 22
WEBSERVICE REST dans WEBDEV 22
Débuté par Laurent, 27 déc. 2018 11:16 - Aucune réponse
Membre enregistré
5 messages
Posté le 27 décembre 2018 - 11:16
Bonjour, svp j'ai des soucis pour gerer la methode POST et PUT du webservice REST webdev

Voici mon bout de code pour le bouton d'ajout de produit developpe sous windev:

sProduitaAjouter est une chaîne
mareq est une httpRequête

stDetailProduit est un STStProduitComplet
stDetailProduit.sCodebarre=SAI_Codebarre
stDetailProduit.sREFERENCE=SAI_REFERENCE1
stDetailProduit.sDesignation=SAI_Designation

Sérialise(stDetailProduit,sProduitaAjouter,psdJSON)

mareq.URL="http://localhost/article"
mareq.Méthode=httpPost
mareq.ContentType="application/json"
mareq.Contenu=sProduitaAjouter

marepons est un restRéponse=RESTEnvoie(mareq)
SI marepons.CodeEtat=201 ALORS
Info(marepons.Contenu)
SINON
Erreur("Echec d'ajout")
FIN.

mais coté webservice, j'ai du mal recuperer le contenu du POST
voici mon bout de code :

PROCEDURE AjouterProduit()

//sDonneesArenvoyer est une chaîne ANSI
sDonneesRecu est une chaîne
StProduitComplet est une Structure
REFERENCE est une chaîne
codebarre est une chaîne
Designation est une chaîne
famille est une chaîne
sousfamille est une chaîne
pu est un monétaire
Photo est un Buffer < Sérialise=Faux>
description est une chaîne
couleur est une chaîne
matière est une chaîne
couleur_bracelet est une chaîne
FIN
//recupere le contenue du POST
sDonneesRecu=PageParamètre(paramBuffer)

stProduitaAjouter est un StProduitComplet
//On verife si les donnees a ajoutyer sont compatuible avec la structure attendue
QUAND EXCEPTION DANS
Désérialise(stProduitaAjouter,sDonneesRecu,psdJSON)
FAIRE
Erreur(ErreurDétectée(errComplet))
SINON
//transferer les donnees recus vers un nouveau produit(creer un nouveau prosduit)
MémoireVersFichier(stProduitaAjouter,ARTICLE)
HAjoute(ARTICLE)
Info("Produit ajouter avec succes")
FIN

Aidez moi svp