PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV (précédentes versions) → lang dans <HTML>
lang dans <HTML>
Débuté par Philippe C., 21 mai 2021 15:08 - 2 réponses
Membre enregistré
62 messages
Posté le 21 mai 2021 - 15:08
Bonjour,

Suite à un audit chez un de nos clients d'un site Web que nous mettons à disposition, nous avons une série de point à mettre à jour.

Un point qui revient à chaque fois est le fait qu'il n'y ait pas de lang dans la balise HTML
<html lang="fr">


J'ai regardé dans l'aide, cherché sur Internet, mais rien ne me renseigne sur comment indiquer la balise lang dans html.
un xml:lang serait accepté, mais je n'ai pas trouvé non plus...

Merci pour l'aide apportée.


Bonne journée,
Membre enregistré
828 messages
Popularité : +2 (2 votes)
Posté le 21 mai 2021 - 17:41
Bonjour,
C'est curieux, cette balise est automatiquement ajoutée. J'ai plusieurs sites et je n'ai jamais ce message d'audit. En affichant le code source cette balise n'est pas présente ?

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube
Membre enregistré
62 messages
Posté le 25 mai 2021 - 09:01
Bonjour,

Oui, dans le code source je n'ai que <html>.

Ce que je vois par contre un peu plus bas c'est ceci :
<meta name="Description" lang="fr" content="">
<meta name="keywords" lang="fr" content="">


Je ne pense pas que ça ait un rapport, mais c'est le seul endroit ou je vois des "fr"...

J'imagine que nous avons raté quelques choses, mais je ne vois absolument pas quoi...

Nous avons aussi des blocages sur des formulaires sans bouton submit.

l'Audit fait 47 pages et on nous demande de corriger au minimum le plus possible d'erreur et pas les warnings...

Petite précision, nous sommes en WebDev 24.


Merci,