PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV (précédentes versions) → [WD17] Problème avec HConstruitValClé
[WD17] Problème avec HConstruitValClé
Débuté par Dominique Gourdier, 22 mai 2018 17:39 - 2 réponses
Posté le 22 mai 2018 - 17:39
Bonjour,

j'ai un soucis avec la commande HConstruitValClé. Mon fichier possède une clé composée faite d'une date et d'une chaine, exemple (sn=c123456 date=22/05/2018 sn_date=c123456,20180522) .
Aucune erreur n'apparait dans mon code lors du lancement du programme:

dAte_cible est un Date
sN_cible est un chaîne
ma_clé est un Buffer
x est un entier=TableSelect(TABLE_Commentaires_fonctionnement)
dAte_cible=TABLE_Commentaires_fonctionnement.COL_Date[x]
sN_cible=TABLE_Commentaires_fonctionnement.COL_Sn_maitre[x]
ma_clé=HConstruitValClé(commentaires_fonctionnement,sn_date,sN_cible,dAte_cible)
Info(sN_cible,dAte_cible,ma_clé)

malheureusement la variable ma_clé ne m'affiche jamais la valeur recherchée mais uniquement la valeur correspondant au champ sn :






Quelle erreur aurais-je commis pour obtenir ce mauvais résultat?
Merci d'avance pour tout aide.
Dominique
Membre enregistré
501 messages
Posté le 25 mai 2018 - 19:15
Bonjour,
Avec un trace ou un point d'arrêt, qu'est ce que ça donne ?

--
Il y a peut être plus simple, mais, ça tourne
Posté le 26 mai 2018 - 12:02
Bonjour,

merci pour la réponse. Trace donnait des résultats encore plus bizarres avec, parfois des caractères coréens ou de ce genre.
J'ai donc décidé de contourner le problème avec une requête et ça marche.
Bon dev...