PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 22 → Récupérer mail structure contact
Récupérer mail structure contact
Débuté par Mathieu B, 03 mar. 2016 09:58 - 1 réponse
//hostimage.webdev.info/avatars/Cv4JXoGmrHbP2mXXLPnrg
Membre enregistré
55 messages
Posté le 03 mars 2016 - 09:58
Bonjour,

Je n'arrive pas très bien à comrendre comment fonctionne la structure contact, et plus particulièrement la variable "..Email".

En effet, je cherche à créer une liste avec les contacts du téléphone de l'utilisateur, et si j'ai bien compris, la variable "..Email" est un tableau ou du moins, se comporte de la même manière. Voici donc le code que j'utilise :

tabContacts = ContactListe();

SI tabContacts..Occurrence > 0 ALORS
// Trie des contacts
TableauTrie(tabContacts, ttMembre, "+Nom")

// Ajout dans la zone répétée
POUR TOUT tContact DE tabContacts
SI tContact..Nom <> "" OU tContact..Prénom <> "" ET Dimension(tContact..Email) > 0 ALORS
ListeAjoute(LISTE_Contacts, tContact..Nom + " " + tContact..Prénom + " | " + tContact..Email[1]);
FIN
FIN
FIN


Or, la fonction Dimension(tContact..Email), me renvoie systématiquement 0 pour tous les contacts, malgré les adresse renseignées dans le répertoire. Une idée ?

Merci

PS : Comment insère t'on du code proprement ?
//hostimage.webdev.info/avatars/UpGCLQY23EKegOlTxYtqdg
Membre enregistré
5 messages
Posté le 14 mars 2017 - 08:48
Bonjour Mathieu,

Je rencontre le même problème... Le tableau est systématiquement vide.
A mon avis un bug de la 22 ou en quelle version es-tu?

Bien à toi.

--
Roby Pratillo
Jennesco SA