PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 22 → Résolution appareil photo
Résolution appareil photo
Débuté par Noah, 13 mai 2017 18:37 - 4 réponses
//hostimage.webdev.info/avatars/n2eeJ2wsPBT4CKevCrtDg
Membre enregistré
18 messages
Posté le 13 mai 2017 - 18:37
Bonjour, j'ai un soucis avec mon code j'ai beau changer la valeur de ma chaîne la résolution de la photo est toujours la même (elle est affiché dans un champ IMG en mode homothétique centré).

Mon code fonctionné au début mais je ne sais pas ce qu'il c'est passé après quelques modifications dans l'application ça ne fonctionne plus.

Vous voyez quelque chose qui cloche dans cette partie du code ?

sListeRésolution est une chaîne
sListeRésolution = "2400 3840"
SI ErreurDétectée = Faux ALORS
VidéoParamètre(vipRésolutionPhoto, sListeRésolution)
SINON
Erreur("Erreur durant la récupération des résolutions supportées par la caméra.")
FIN
gsCertificat_immatriculation = VidéoLanceAppli(viCaptureImage)
SI gsCertificat_immatriculation <> "" ALORS
Info("Photo sauvegardée dans le fichier " + gsCertificat_immatriculation)
IMG_certificat_immatriculation = gsCertificat_immatriculation
BTN_certificat_immatriculation..Visible = Faux
FIN


Merci :)
//hostimage.webdev.info/avatars/dUKdE29l0tYWi5tsX27JUQ
Membre enregistré
59 messages
Posté le 13 mai 2017 - 19:23
sListeRésolution est une chaîne
sListeRésolution = "2400"+TAB+"3840"

MayBe ? =D
//hostimage.webdev.info/avatars/n2eeJ2wsPBT4CKevCrtDg
Membre enregistré
18 messages
Posté le 13 mai 2017 - 20:49
Jennifer a écrit :
sListeRésolution est une chaîne
sListeRésolution = "2400"+TAB+"3840"

MayBe ? =D


J'ai bien modifié cette ligne

sListeRésolution = "2400" + TAB + "3840"

Mais la résolution de la photo est toujours la même, mais ce qui est étrange c'est que ça fonctionné correctement avant.

Et ce que je dois modifier cette ligne ?

VidéoParamètre(vipRésolutionPhoto, sListeRésolution)

ou

VidéoParamètre(vipRésolutionPhoto, ExtraitChaîne(sListeRésolution, rangDernier, RC))


Merci
Message modifié, 13 mai 2017 - 20:52
//hostimage.webdev.info/avatars/dUKdE29l0tYWi5tsX27JUQ
Membre enregistré
59 messages
Posté le 13 mai 2017 - 22:48
Ce n'est pas normal, mais sous quel environnement travails-tu ? Sache que cette option n'est pas disponible sous IOS.
Tu peux passer sinon par le biais d'un redimensionnement de l'image (ce que je fais par principe de compatibilité)

lc_sPhoto est une chaîne
lc_RecupImg est une Image

// Prise de la photo
lc_sPhoto = VidéoLanceAppli(viCaptureImage)

SI lc_sPhoto <> "" ALORS

lc_RecupImg = dChargeImage(lc_sPhoto)
dRedimensionne(lc_RecupImg,cs_image_largeur,cs_image_hauteur)

FIN


Après moi je l'enregistre dans une BDD, mais tu peux l'enregistrer dans un fichier.
//hostimage.webdev.info/avatars/n2eeJ2wsPBT4CKevCrtDg
Membre enregistré
18 messages
Posté le 14 mai 2017 - 08:08
Jennifer a écrit :
Ce n'est pas normal, mais sous quel environnement travails-tu ? Sache que cette option n'est pas disponible sous IOS.
Tu peux passer sinon par le biais d'un redimensionnement de l'image (ce que je fais par principe de compatibilité)

lc_sPhoto est une chaîne
lc_RecupImg est une Image

// Prise de la photo
lc_sPhoto = VidéoLanceAppli(viCaptureImage)

SI lc_sPhoto <> "" ALORS

lc_RecupImg = dChargeImage(lc_sPhoto)
dRedimensionne(lc_RecupImg,cs_image_largeur,cs_image_hauteur)

FIN


Après moi je l'enregistre dans une BDD, mais tu peux l'enregistrer dans un fichier.


Je travail avec un appareil Android mais je pense que dans mon projet il doit y avoir quelque chose qui pose un conflit avec ce paramètre. Mais comme sous IOS cette fonction n'est pas disponible j'ai autant redimenssionner mon image, merci ;)